Implement Courgette algorithm for updates

RESOLVED DUPLICATE of bug 504624

Status

()

defect
RESOLVED DUPLICATE of bug 504624
6 years ago
6 years ago

People

(Reporter: areinald.bug, Assigned: areinald.bug)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Updated

6 years ago
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 504624
Assignee

Comment 2

6 years ago
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #1)
> 
> *** This bug has been marked as a duplicate of bug 504624 ***

1. I think mobile users (mostly ELF-ARM based devices) would largely benefit from this algo too (the current implementation already includes the necessary disassembler)
2. My skills are largely Mac OS centric, so I plan to add the mach-o binary format as it will be my primary platform.

It's fine to switch to bug 504624, but then it would make sense to remove "Windows" and "nightly" keywords from its title. Are you OK with that ?
Flags: needinfo?(benjamin)

Comment 3

6 years ago
Yes. Although note that we don't/can't make binary diffs for android, so this can't help Android users at the moment. I don't know how updates are deployed to B2G devices, but I suspect we don't use binary diffs there either yet.
Flags: needinfo?(benjamin)
You need to log in before you can comment on or make changes to this bug.