ZTE Open device ships locked

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
5 years ago
10 months ago

People

(Reporter: cwiiis, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [d-watch])

(Reporter)

Description

5 years ago
The ZTE Open ships in a state where it's impossible to modify system files or flash a new image. (at least it seems that way - I'd love to be wrong)

This is pretty bad for prospective FirefoxOS developers, as it ships with quite an outdated version of FirefoxOS, and I don't see there being any guarantees of it being kept up to date in the future.

This blog post lists how to root and flash images: http://pof.eslack.org/2013/07/05/zte-open-firefoxos-phone-root-and-first-impressions/ but that takes advantage of a kernel vulnerability, so is (hopefully) not likely to remain too long.

Given that this is a Firefox-branded device, this seems like a pretty poor state of affairs. The 'Open' in the name is extremely misleading, as the device is about as open as any Android device, and perhaps less so, as the trend in Android devices is to ship with a locked, but unlockable bootloader.

Is there anything we can do to remedy this situation? Given that this ships with our branding (orange, with 'FirefoxOS' printed on the back), which I assume we had to grant, this gives a pretty bad impression. I don't see how this aligns with the Mozilla core values.
The issue with the vulnerability is bug 909345
(Reporter)

Comment 2

5 years ago
It's also worth noting that even following the instructions in that blog post, it's still not possible to flash images from a b2g build-tree - at least, it certainly isn't easy or obvious.
Whiteboard: [d-watch]

Comment 3

5 years ago
For those ZTE open market phones that we bought at eBay, ZTE will enable Fastboot through a new update via FOTA next Thursday. I will keep you posted.

Comment 4

5 years ago
On ZTE's home page appeared updates: 

For the European version: http://www.ztedevices.com/support/smart_phone/cba40ed6-d3ab-44c0-bdee-3a15803dc187.html?type=software
For the US version: http://www.ztedevices.com/support/smart_phone/b5a2981a-1714-4ac7-89e1-630e93e220f8.html?type=software

I tried to install the European version as a sdcard update with the recovery mechanism. Everything worked. (I was a bit suprised that all my user data was gone ... because there was no warning that this will hapen.)

I then tried to use fastboot as in http://pastebin.mozilla.org/2992044 but was not able to flash a boot partition. Maybe I am doing something wrong? 

A general suggestion would be: There should be some possibility to backup and restore user data when applying ZTE's own upgrade, I think.
These images are restore images. None of them will allow to unlock the bootloader yet.

The latest info is that ZTE will provide an update (OTA?) next week to allow unlocking the bootloader.
(In reply to Hubert Figuiere [:hub] from comment #5)
> These images are restore images. None of them will allow to unlock the
> bootloader yet.
> 
> The latest info is that ZTE will provide an update (OTA?) next week to allow
> unlocking the bootloader.

Did that happen?
AFAIK it did. But you should needinfo jguo for that. I don't have the device to even test this.
Flags: needinfo?(jguo)
(In reply to Aaron Train [:aaronmt] from comment #6)
> Did that happen?

Yes. However, the fastboot enabled boot.img still doesn't accept unsigned builds, so while flashing your own build onto the device now works, the device won't boot up past the splash screen. See also bug 925502 (which is slightly out of date right now) and, more importantly, the discussion at https://groups.google.com/forum/#!topic/mozilla.dev.b2g/S5gNK3Mj22k for more information and a solution.

For the sake of having all the information in one place: the problems with the current boot.img are threefold:
1) It blocks unsigned builds
2) Its rilproxy service conflicts with the one built into newer B2G branches
3) It doesn't mark some important b2g files as executable.

Eduardo González' modified boot.img fixes these problems, allowing the device to boot and work correctly with newer versions of B2G (I'm currently in the process of confirming the rilproxy fix, as I was using an older source of information before).
I can confirm that the modified boot.img fixes the rilproxy problem as well.
Fastboot works with v1.1 build 2 and the boot.img included in their v1.2 package makes it so that images don't need to be signed. However it still has the other problems:
1) Several important files are read only. This apparently isn't a problem for their package, but it produces bug 925502 when you build your own.
2) It doesn't disable the RIL proxy service. This also isn't a problem for their build, but with a custom build it means you can't use your SIM card.

I attached modified boot images in bug 925502 comment #27 and bug 925502 comment #30 that apply the same changes made previously by Eduardo González [0], and with that I can successfully flash the device to v1.3. I've been using v1.3 for about a week now without difficulty.

[0] http://sl.edujose.org/2013/10/adapted-boot-image-for-use-with-b2g.html

Comment 13

10 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.