View source syntax highlighting doesn't follow parser in strict mode.

VERIFIED DUPLICATE of bug 91046

Status

()

Core
HTML: Parser
--
minor
VERIFIED DUPLICATE of bug 91046
17 years ago
17 years ago

People

(Reporter: armccurdy, Assigned: harishd)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Build    : 2001071604
Platform : Win2k

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">
<html>
<head></head>
<body>
<!-- Strictly, this is a comment --<> Strictly, this is NOT a comment -->
</body>
</html>

Although the browser window displays the correct thing here, the 'view source'
syntax highlighting suggests the comment extends to the '-->'

Updated

17 years ago
Blocks: 57724
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All
(Assignee)

Comment 1

17 years ago
*** Bug 91046 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 2

17 years ago
patch in bug 91046.
My patch has a regression: The '/' in an empty tag like <hr /> gets lost in
standards mode. I'm working on more similar view-source bugs and will address
this.

BTW, I don't understand the code at
http://lxr.mozilla.org/seamonkey/source/htmlparser/src/nsHTMLTokenizer.cpp#624 .
Why can an "attribute" named '/' be usable in quirks mode? I think it is usable
only for detecting an empty element and for view-source.
Keywords: patch
(Assignee)

Comment 4

17 years ago
We're trying to support XHTML syntax and XHTML by default operates in strict mode.
No longer blocks: 57724

*** This bug has been marked as a duplicate of 57724 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

17 years ago
QA Contact: bsharma → moied
Reopening 57724 dependencies for independent resolution.
Status: RESOLVED → REOPENED
Depends on: 57724
Keywords: patch
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 91046 ***
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 8

17 years ago
Verified Duplicate of 91046 

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.