Closed Bug 910459 Opened 8 years ago Closed 2 years ago

Mozmill test to verify Stub Installer installs the correct build

Categories

(Mozilla QA Graveyard :: Mozmill Tests, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: u279076, Unassigned)

References

(Depends on 1 open bug)

Details

(Whiteboard: [blocked by bug 911048])

Today I discovered that the Aurora stub installer was downloading Firefox 24.0a2 20130805 instead of Firefox 25.0a2 20130828 (latest-mozilla-aurora). Going forward we will need to perform a manual spotcheck to ensure the stub installer is working properly. I'd like to see if this is something that could be covered by automation.

1. Download the stub installer by loading the website for each branch:
> Nightly: nightly.mozilla.org
> Aurora: aurora.mozilla.org
> Beta: beta.mozilla.org
> Release: www.mozilla.org
2. Click the green button to download the stub installer
3. Run the stub installer and let it install Firefox
4. Start Firefox and verify the User Agent string in about:support matches the build we expect

Ideally this should be performed with all branches and locales. Is this something we can automate in Mozmill or some other tool?
Also CCing Stephen Donner in case there's something WebQA can do to help here.
Sorry, but the stub installer cannot be automated as of now. See bug 799844.
Depends on: 799844
Whiteboard: [qa-automation-blocked]
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #1)
> Also CCing Stephen Donner in case there's something WebQA can do to help
> here.

I don't believe we can do the end-to-end testing that would be required for all the steps in comment 0, sorry (but if there's a way we can help verify anything along the way, individually, let us know).
Depends on: 799406
No longer depends on: 799844
Sorry that I was referencing the wrong bug here. But we are actually blocked on bug 799406. As long as there is no silent mode we cannot support the stub installer.

Anthony, for manual testing you could half-wise automate it. The most recent mozdownload 1.9 release can download stub installers now.
No longer depends on: 799406
We should be able to get mozinstall to handle the stub installer. I filed bug 911048 for it.
Depends on: 911048
Priority: -- → P1
Whiteboard: [qa-automation-blocked] → [blocked by bug 911048]
Priority: P1 → P2
Mozmill is dead, WONTFIX the remaining bugs.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
Product: Mozilla QA → Mozilla QA Graveyard
You need to log in before you can comment on or make changes to this bug.