[B2G][Helix][messages][zhaotao]ucs2 coded cell broadcast message can not be shown correctly

RESOLVED WORKSFORME

Status

P2
normal
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: lecky.wanglei, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; aff-kingsoft-ciba; Zune 4.7)

Steps to reproduce:

1.send a ucs2 coded cell broadcast message to ffos phone
2.check the ucs2 coded cbs on ffos phone


Actual results:

2.ffos phone can not display the ucs2 coded cbs correctly


Expected results:

ucs2 coded cbs should be displayed correctly
(Reporter)

Updated

5 years ago
blocking-b2g: --- → hd?
Component: General → Gaia::SMS
Priority: -- → P2
Blocks: 710489
Component: Gaia::SMS → DOM: Device Interfaces
Product: Boot2Gecko → Core
Hi, we do have already some test cases for UCS2 CBM[1].  Could you provide detailed test case you used or even better some log capture for further analysis?

[1]: http://mxr.mozilla.org/mozilla-central/source/dom/cellbroadcast/tests/marionette/test_cellbroadcast_gsm.js#244
Component: DOM: Device Interfaces → RIL
Product: Core → Boot2Gecko
(Reporter)

Updated

5 years ago
Summary: [B2G][Helix][messages]ucs2 coded cell broadcast message can not be shown correctly → [B2G][Helix][messages][zhaotao]ucs2 coded cell broadcast message can not be shown correctly
(Reporter)

Updated

5 years ago
blocking-b2g: hd? → ---
(Reporter)

Comment 2

5 years ago
hi,vicamo,

We think this issue should be caused by QCRIL--the handling of ucs2 should be big endian(little endian now)

We are still working on it,we will update if there is any more progress.
(Reporter)

Comment 3

5 years ago
hi,all

this issue is caused by QCRIL and we have fixed it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.