Closed Bug 910596 Opened 6 years ago Closed 6 years ago

Defect - File total size reported as unknown while Firefox desktop displays the correct value

Categories

(Firefox for Metro Graveyard :: Downloads, defect)

All
Windows 8.1
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 910597

People

(Reporter: flod, Unassigned)

Details

Attachments

(1 file)

Firefox 2013-08-28 on Windows 8 Professional 64bit.

Try to download this file with Metro
ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/23.0.1/mac/en-US/Firefox%2023.0.1.dmg

Total file size will be reported as unknown.

Try to download the same file with Firefox on desktop and download manager reports the correct file size (42.3 MB).
Summary: File total size reported as unknown while Firefox desktop displays the correct value → Defect - File total size reported as unknown while Firefox desktop displays the correct value
Whiteboard: [preview-triage] feature=defect c=tbd u=tbd p=0
Hi Juan, can you verify and provide steps to reproduce.
Flags: needinfo?(jbecerra)
I tried downloading the file on Metro Firefox and it shows the total file size.  This may have been fixed at some point? Please re-open if you can still reproduce.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(jbecerra)
Resolution: --- → WORKSFORME
No longer blocks: metrov1backlog
Whiteboard: [preview-triage] feature=defect c=tbd u=tbd p=0
Just tested again on Fx 26.0a1 (2013-09-11).

I'm on a VM from the Paris office, so connection and environment are different but the results is the same.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
both Desktop and Metro tests are being done in the same VM and both in the Paris office right?
Yes, it's the same version of Nightly, on the same VM and network.
Resetting back to Juan, I can't reproduce but Francesco definitely can.  Maybe you can find some extra steps that differentiate our two setups or something.
Flags: needinfo?(jbecerra)
Tested on 2013-09-16 I haven't been able to reproduce this on an en-US build while trying to download different types of files including the one in the original report. I will try downloading an localized nightly build and see if there's something there.
Flags: needinfo?(jbecerra)
A localized nightly (it) built from the 11th also didn't show this problem. I tried navigating to the file through the ftp directory as well as trying typing the link as in comment #0.
I am able to reproduce this problem after changing the Clock, Language, Region settings in Windows by changing the "." separator to "," in the number formats (Additional Settings).
Should be fixed by the patch in bug 910597.  Juan could you please verify on tomorrow's nightly build or later?
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Flags: needinfo?(jbecerra)
QA Contact: jbecerra
Resolution: --- → DUPLICATE
Duplicate of bug: 910597
This is now working on the latest nightly built from http://hg.mozilla.org/mozilla-central/rev/ab4ccf3d6b60

I tested by toggling the region settings corresponding to decimal separators and in both cases, using "." vs ",", I got a total file size and current download size reported.
Flags: needinfo?(jbecerra)
Thanks for verifying.
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.