Closed Bug 910835 Opened 8 years ago Closed 8 years ago

NullPointerException at BrowserSearch.showSuggestionsOptIn (line 449)

Categories

(Firefox for Android Graveyard :: Awesomescreen, defect)

ARM
Android
defect
Not set
normal

Tracking

(fennec26+)

RESOLVED DUPLICATE of bug 912524
Tracking Status
fennec 26+ ---

People

(Reporter: mcomella, Assigned: mcomella)

References

Details

Attachments

(1 file)

1) Open fennec on a clean profile (after "clear data")
2) Click the URL bar
3) Type in "apple.com"
4) Click the tab bar
5) Create a new tab
6) Click the URL bar
7) Type in "app"

Expected: No crash, search suggestions opt in is shown eventually
Actual: NullPointerException and fennec crash occurs right after search provider opt-in and search providers are shown

This does not occur if the first website is not visited.

Note that this is tested on a local build, rather than a Nightly.
Attachment #797406 - Attachment mime type: text/x-vhdl → text/plain
tracking-fennec: --- → ?
Not hitting this with those steps on Nightly (09/04). Fixed?
I was able to repo on my local build again, just pulled from fxteam:

https://crash-stats.mozilla.com/report/index/6ede5e2e-8460-445b-bd4b-58bde2130904

(I'm not sure why the crash reporter came up but it did.)

The repo steps have to be done quickly and things seem to load more slowly on my local build which makes it easier to do. I'll see if I can find a device to do it with Nightly.
Repoed on an armv6 - LG Optimus Slider. It's probably a timing issue.
And I was unable to repo on my Galaxy Nexus and blassey's x86 phone (which was also really fast).
Assignee: nobody → michael.l.comella
Status: NEW → RESOLVED
tracking-fennec: ? → 26+
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 912524
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.