URL bar's shadow shouldn't be shown when search suggestions opt-in is shown

VERIFIED FIXED in Firefox 26

Status

()

defect
VERIFIED FIXED
6 years ago
3 years ago

People

(Reporter: sriram, Assigned: sriram)

Tracking

({polish})

unspecified
Firefox 27
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox26 verified, firefox27 verified)

Details

Attachments

(1 attachment)

As the summary says..
Here is the problem. Though I can hide it when we show suggestions prompt, when the keyboard is dismissed, the LayerView sets the shadow back to true. (why? why?? why??). We use the same browser-toolbar and giving the control to LayerView is a big problem!!

Suggestions:
1. Change the background color of suggestions prompt and leave the shadow to be shown always.
2. Change the LayerView not to overscroll.
Keywords: polish
Not sure I understand the problem here. Is it just that the bottom line in the toolbar has the same color than the suggestion opt-in UI?
Posted patch PatchSplinter Review
Making the background a light blue, so that the shadow can still stay, yay!
And the text color is tweaked a little bit, as per Ian's suggestion.
Attachment #809351 - Flags: review?(margaret.leibovic)

Updated

6 years ago
Attachment #809351 - Flags: review?(margaret.leibovic) → review+
https://hg.mozilla.org/mozilla-central/rev/bf0a94794cc5
Assignee: nobody → sriram
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 27
Comment on attachment 809351 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Having the URL bar's shadow shown always.
User impact if declined: Awkward blue color with dividers in-between.
Testing completed (on m-c, etc.): Landed long long ago.
Risk to taking this patch (and alternatives if risky): None. Just layout changes.
String or IDL/UUID changes made by this patch: None.
Attachment #809351 - Flags: approval-mozilla-aurora?
Attachment #809351 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.