Closed Bug 911010 Opened 6 years ago Closed 6 years ago

[B2G][Helix][dialer][tongxiao]The emergency call Interface is wrong.

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect, P2)

defect

Tracking

(blocking-b2g:hd+, b2g-v1.1hd fixed, b2g-v1.2 fixed)

RESOLVED FIXED
blocking-b2g hd+
Tracking Status
b2g-v1.1hd --- fixed
b2g-v1.2 --- fixed

People

(Reporter: lecky.wanglei, Assigned: dwi2)

References

Details

Attachments

(6 files)

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; MALC; aff-kingsoft-ciba; .NET4.0C; .NET4.0E; Tablet PC 2.0)

Steps to reproduce:

【Detail Description*】:The emergency call Interface is wrong
【Repro Steps*】:Make a emergency call.
【Expect Result*】:The interface  dispaly string of  "Emergency number".
【Real Result*】:The interface  dispaly string of  "Emergency num。。。".
【Test Count*】:10
【Found Count*】:10
【Gaia commit ID*】:
【Gecko commit ID*】: 
【Log*】:the picture of the interface
【Network environment】:
【Resume operation】:no
【Carrier】:
Severity: normal → blocker
blocking-b2g: --- → hd?
Priority: -- → P2
【Gaia commit ID*】:c0ea0a4943dc8d3751b07f5b5c5d3abe06364a14  
【Gecko commit ID*】: c0ea0a4943dc8d3751b07f5b5c5d3abe06364a14
Any update?
 Any update?
What is the reason of this porblem ?
Hi ,
    What is the reason of this porblem ?
Flags: needinfo?(wchang)
Evelyn,

Are we able to correct the string truncate here?
Severity: blocker → normal
Flags: needinfo?(wchang) → needinfo?(ehung)
we should make font size smaller instead of truncating string, I think.

tzhuang, can you help on this?
Flags: needinfo?(ehung) → needinfo?(tzhuang)
Hi,
   any update?
I made a mockup of emergency call screen with smaller font size (from 3.3rem to 2.8 rem).
But we need UX team to approve this modification.
Assignee: nobody → tzhuang
Flags: needinfo?(tzhuang)
Attached image with font-size: 3.29rem
modified font-size from 3.3rem to 3.29 rem. (The image is capture from Helix)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attached file pull request
Attachment #810360 - Flags: review?(anthony)
Comment on attachment 810360 [details]
pull request

I believe this bug is caused by a rounding issue because every device as the same CSS width. So this might happen on other devices. I think a safer (and simpler) fix would be to change the original value to 3.2rem.
Attachment #810360 - Flags: review?(anthony) → review-
Comment on attachment 810360 [details]
pull request

Hi rik,

I've update pull request as review comment. 3.2rem font works fine both on Helix (WVGA) and ZTE Open (HVGA).
Please kindly help to review it again. Thanks.
Attachment #810360 - Flags: review- → review?(anthony)
Comment on attachment 810360 [details]
pull request

><!DOCTYPE html>
><html>
>  <head>
>    <meta charset="utf-8">
>    <meta http-equiv="Refresh" content="1; url=https://github.com/mozilla-b2g/gaia/pull/12462">
>    <title>Redirect to Pull Request</title>
>  </head>
>  <body>
>    Redirect to <a href="https://github.com/mozilla-b2g/gaia/pull/12462">pull request 12462</a>...
>  </body>
></html>
Attachment #810360 - Flags: review?(anthony) → review+
Victoria: We're changing the font-size for the number/name from 33px to 32px. Are you ok with it?
Flags: needinfo?(vpg)
Hi Anthony, 
Thanks, can you post a screenshot of the change? is it this one?: https://bug911010.bugzilla.mozilla.org/attachment.cgi?id=810347
I don0t have a problem with 1 px change in this big size font, but in general, the layout is not correct, it has been a regression a while ago, please see this bug: 
https://bugzilla.mozilla.org/show_bug.cgi?id=883110

Thanks!
Flags: needinfo?(vpg)
Tzu-Lin: Could you post a screenshot with the 32px font for Victoria?
Flags: needinfo?(tzhuang)
Hi all,

Here's the screenshot with 32 px font on ZTE Open.
I don't have Helix at hand right now. I'll upload screenshot of Helix as soon as I got Helix.

Thanks
Flags: needinfo?(tzhuang)
Tzu-Lin: Those screenshots look like they come from a different branch. The Helix screenshot is missing the "place new call button" and the font on the ZTE open screenshot seems different. Could you attach screenshots with tip of master?
Flags: needinfo?(tzhuang)
Hi,
The type size looks ok but there are a few other things wrong in this screen, noe is relative to the blue area height, please see: https://bugzilla.mozilla.org/show_bug.cgi?id=883110
And the other is, as Anthony said, the place call button in the button pad. But, when adding this button, please change the height of this component as this extra element made me redesign the button pad to have better proportions with the new number of elements. You can see specs for that pad specific sizes here: https://bug920526.bugzilla.mozilla.org/attachment.cgi?id=809867 (please, I am mentioning this specs only for the button pad spec part)

Thanks!
V

(In reply to tzhuang [:tzhuang] from comment #19)
> Created attachment 812952 [details]
> emergency call with 32 px font on helix
Depends on: 883110
If the font size looks ok, we can land this then. And we'll fix the other call screen layout issues in the other bugs Victoria opened.
Flags: needinfo?(tzhuang)
Landed with https://github.com/mozilla-b2g/gaia/commit/c3bb0282f306cfbb4112aedb835d676f4a965127
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Hi all,
The Helix screenshot is based on 1.1.0hd branch. This is because all our Helix devices with latest ROM are broken. The ROM image vendor recently provided wiped out IMEI and MAC address of the phone. It is impossible to make emergency call without IMEI. So I made the font change on a v1.1.0hd device and take the screenshot.
blocking-b2g: hd? → ---
Hi,
  will you solve this problem in the 1.1hd?
Flags: needinfo?(wchang)
HD layout work. 
Please have this landed on hd and koi(if applicable).
blocking-b2g: --- → hd+
Flags: needinfo?(wchang)
(In reply to Anthony Ricaud (:rik) from comment #20)
> Tzu-Lin: Those screenshots look like they come from a different branch. The
> Helix screenshot is missing the "place new call button" and the font on the
> ZTE open screenshot seems different. Could you attach screenshots with tip
> of master?

I believe "place new call" function is not available on v1.1/HD, that's why it doesnt show on helix and this is expected. Correct me if i am wrong :)
(In reply to Wayne Chang [:wchang] from comment #27)
> I believe "place new call" function is not available on v1.1/HD, that's why
> it doesnt show on helix and this is expected. Correct me if i am wrong :)
Yes, that's exactly why.
 Hi Beatriz:
   As Comment 27, they will not be available on v1.1.
   Do you accept that we do not modify this problem ?
Flags: needinfo?(brg)
(In reply to Anthony Ricaud (:rik) from comment #23)
> Landed with
> https://github.com/mozilla-b2g/gaia/commit/
> c3bb0282f306cfbb4112aedb835d676f4a965127

Hi Tim,

Please help to land this on hd and v1.2.

Thanks!
Flags: needinfo?(timdream)
Keywords: checkin-needed
(In reply to lecky from comment #29)
>  Hi Beatriz:
>    As Comment 27, they will not be available on v1.1.
>    Do you accept that we do not modify this problem ?
Thanks for fixing the "Emergency call" label size, the hd+ is already set.
Regarding multiparty calls(place new call option) is a new feature available in 1.2, not in 1.1. (Thanks everyone for your confirmations here)
Flags: needinfo?(brg)
(In reply to Wayne Chang [:wchang] from comment #30)
> (In reply to Anthony Ricaud (:rik) from comment #23)
> > Landed with
> > https://github.com/mozilla-b2g/gaia/commit/
> > c3bb0282f306cfbb4112aedb835d676f4a965127
> 
> Hi Tim,
> 
> Please help to land this on hd and v1.2.
> 
> Thanks!

Unfortunately this is not upliftable to v1.1.0hd. :rik, could you push a v1.1.0hd specific patch?
Flags: needinfo?(timdream) → needinfo?(anthony)
PS I believe someone else will uplift hd+ and koi+ bugs to v1.2 altogether.
v1.2: 8e1c2f2db3891d47864adc338469b976d9cb6f32
v1.1.0hd: dc8f0a4528d93573d566b717d268ead5553959eb
Flags: needinfo?(anthony)
You need to log in before you can comment on or make changes to this bug.