[Call Log] Does not update call log when deleting contacts

RESOLVED DUPLICATE of bug 976990

Status

Firefox OS
Gaia::Dialer
P1
major
RESOLVED DUPLICATE of bug 976990
4 years ago
3 years ago

People

(Reporter: Leo, Unassigned)

Tracking

unspecified
1.1 QE6
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-)

Details

(Whiteboard: [TD-84166][POVB])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
1. Title : Does not update call log when deleting contacts 
2. Precondition : Save 2 logs in call log
3. Tester's Action : Save 2 logs to contacts, and delete each contacts
4. Detailed Symptom : Sometimes, does not update call log
5. Expected : Should update call log
6. Reproducibility: Y
1) Frequency Rate : 100%
7. v1-train : Reproduced
8. Gaia Revision : 0d5a9a7577f16b6a72a982148c6f509ee1714ea2
9. Personal email id : promise09th@gmail.com
(Reporter)

Comment 1

4 years ago
Created attachment 797674 [details]
Bug_911025.mp4

Master : does not reproduce
v1-train : reproduce

But, I don't know why v1-train is reproduced and master is not reproduced...

Please check this
Adding qawanted to check a)if its a regression b)happens on our build or its only on the partner buid given this is not reproducible on master.

Updated

4 years ago
Keywords: qawanted

Updated

4 years ago
QA Contact: dsubramanian

Comment 3

4 years ago
On Mozilla build, One of the contact's name is still found on the call log as per the video attachment. 

On partner build, both the contact still have names on the call log and is not updated immediately. 

Upon killing the process and returning to the call log again, the user is able to see updated call logs with phone numbers. 

Environmental Variables:
Leo Build ID: 20130830041201
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/2fb19341d934
Gaia: 577ab5105af418efc8ded00798fd3644b3dac674
Platform Version: 18.1

Leo Partner build ID: 20130828155538
Gecko: /rev/
Gaia: bcfbffbbb59406b8a07def8ab264792c8d28f23a
Platform Version: 18.1
Keywords: qawanted
(Reporter)

Comment 4

4 years ago
In my leo test version, 

1. I add mozConatcts.getRevision() API locally.(Before this API is not available in leo official version)
2. Use v1-train of gaia(in leo version, Bug 862385 patch is not applied. So, I use v1-train of gaia)

When you check this issue, you consider this information please
(Reporter)

Updated

4 years ago
blocking-b2g: leo? → leo+
(Reporter)

Updated

4 years ago
Priority: -- → P1
Whiteboard: [TD-84166]

Comment 5

4 years ago
(In reply to Leo from comment #4)
> In my leo test version, 
> 
> 1. I add mozConatcts.getRevision() API locally.(Before this API is not
> available in leo official version)
> 2. Use v1-train of gaia(in leo version, Bug 862385 patch is not applied. So,
> I use v1-train of gaia)
> 
> When you check this issue, you consider this information please

Sorry, I don't get this.

In order to make the call log contacts cache work, Bug 862385 patch needs to be applied and mozContacts.getRevision() needs to be available. You are saying that this requirements are not fulfilled in leo official version. Are you suggesting an uplift problem?
(Reporter)

Comment 6

4 years ago
I'm sorry to confuse you.

I mean that :

mozContacts.getRevision() is not available in leo official version
-> So, we add this function. It is working fine. But, if we add this function, this issue is reproduced, too.

Comment 7

4 years ago
What do you mean with "we add this function"? Do you apply the patches for bug 864556 and maybe bug 899181?

Which Gecko commit corresponds with leo official version?
(Reporter)

Comment 8

4 years ago
I select wrong word...

In leo official version, bug 899181 is reproduced. Our gecko engineer said that most of bug 864556 patch is applied, but below code is not applied ...

/dom/interfaces/contacts/nsIDOMContactManager.idl
===============================================================
 interface nsIDOMContactManager : nsISupports
 {
   nsIDOMDOMRequest find(in nsIContactFindOptions options);
 
   nsIDOMDOMCursor getAll(in nsIContactFindSortOptions options);
 
   nsIDOMDOMRequest clear();
 
   nsIDOMDOMRequest save(in nsIDOMContact contact);
 
   nsIDOMDOMRequest remove(in nsIDOMContact contact);
 
   nsIDOMDOMRequest getSimContacts(in DOMString type);
 
   attribute nsIDOMEventListener oncontactchange;
+
+  nsIDOMDOMRequest getRevision();
 };
===============================================================

So, gecko enginner add this code. 
When adding this code, getRevision() function is worked normally.

Comment 9

4 years ago
Thanks for clarifying it :)

Let me summarize what I understood from your explanation:

1. Leo v1.1 official version has most part of bug 864556 applied (this way [1])
2. With the above patch applied, you can reproduce bug 899181. As you mentioned, the changes in the idl were not applied during the uplift of the patches from bug 864556. But did you noticed that there were other missing parts?
3. To fix bug 899181, instead of applying the suggested fix [2], your Gecko engineer did the patch that you mentioned in comment 8. Which is adding the "getRevision()" function to dom/interfaces/contacts/nsIDOMContactManager.idl (without changing the interface uuid).

If the above situation is correct (please, correct me if I am wrong), I think that the error might be caused by step 3. Can you try applying the patch at [2] instead of applying the patch suggested by your Gecko engineer, please? Note that there are a few missing pieces.

FTR, I am not able to reproduce this issue with Mozilla b2g18 + Gaia v1-train, so I am setting this issue as POVB.

[1] https://hg.mozilla.org/releases/mozilla-b2g18/rev/03f5da3acb5b
[2] https://hg.mozilla.org/releases/mozilla-b2g18/rev/44de5fb4e8d0
Whiteboard: [TD-84166] → [TD-84166][POVB]
minus, since it is a POVB issue.
blocking-b2g: leo+ → -
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 976990
You need to log in before you can comment on or make changes to this bug.