Bidi/right-to-left style seems to be too inclusive

RESOLVED DUPLICATE of bug 83958

Status

()

Core
Layout: Text
RESOLVED DUPLICATE of bug 83958
17 years ago
10 years ago

People

(Reporter: Andrew Thompson, Assigned: mkaply)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Go here, and scroll to the bottom:

http://www.columbia.edu/kermit/utf8.html

Look at the Yiddish and Hebrew examples given near the bottom of this page. The
bold text labels have been arranged on the right of the Yiddish and Hebrew
sample texts. However, when one does view source, the HTML looks like this
(assuming the unicode pastes in here ok):


<
b

>Hebrew</

b

<

>: 



>

span

.</

??? ??? ??? ????? ??? ?? ??? ??? ???? ??

>

JI

=

lang

rtl 

=

dir

span

>: <

a

>(1)</

"#note1"

=

href

a

><

b

>Yiddish</

b

<

>

b

>Hebrew</

b

><

a

href

=

"#note1"

>(1)</

a

>: <

span

dir

=

rtl 

lang

=

HE

>

??? ???? ????? ?????? ??? ?? ???? ??

.</

span

>

(i think its utterly failed to paste properly... but go look at the page source
yourself). 

If you can make it out, you'll see that the Yiddish/Hebrew sample text is
encased in a <span dir="rtl"> the bold headings (which read "Yiddish" and
"Hebrew") are outside of the RTL span and therefore should appear on the left of
the page not the right (incidentally this is what IE 5.5 does on the same platform).
I see the problem at this URL in 0.9.2, but not in today's build, so I consider
this to be a dupe of bug 83958, which was fixed just after 0.9.2.

Reporter, were you using a build from before the end of June 2001? Can you test
this with a recent nightly build and confirm whether this is indeed a dupe? By
the way, you might want to consider using the Bugzilla Helper to report bugs,
since it automatically inserts information in the bug report concerning the
build you are using.
(Reporter)

Comment 2

17 years ago
Yup, works for me in 2001071604. Sorry. So used to using nightlies I forgot I
was using something as old as 0.9.2. Should have said that in the bug report...

*** This bug has been marked as a duplicate of 83958 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: giladehven → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.