[B2G][Helix][Setting][Battery][shijinde]the phone will turn off when charging and the battery power is lower 2%

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Settings
P2
normal
RESOLVED WORKSFORME
4 years ago
2 years ago

People

(Reporter: lecky, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(blocking-b2g:-)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; aff-kingsoft-ciba; .NET4.0C; .NET4.0E; Zune 4.7; Tablet PC 2.0)

Steps to reproduce:

1、the battery power is lower 2%
2、using usb to charging


Actual results:

1、the phone can't power off automatically.
2、the phone is charging with usb


Expected results:

1、the phone power off automatically
(Reporter)

Comment 1

4 years ago
gaia:c0ea0a4943dc8d3751b07f5b5c5d3abe06364a14  
gecko:170f9e477571127cd40997fa2abe262ed43f0e4d

software:
Boot2Gecko 1.1.0.0hd-prerelease
Severity: normal → critical
blocking-b2g: --- → hd?
Priority: -- → P1
(Reporter)

Updated

4 years ago
Summary: [B2G][Helix][Setting][Battery][shijinde]the phone can't poweroff automatically when charging and the battery power is about 2% → [B2G][Helix][Setting][Battery][shijinde]the phone will turn off when charging and the battery power is lower 2%
(Reporter)

Comment 2

4 years ago
I had changed battery_manager.js, and the modify code is:

    if (battery.level <= this.AUTO_SHUTDOWN_LEVEL && !battery.charging)
    {
      SleepMenu.startPowerOff(false);
    }

this code in checkBatteryDrainage function.
(Reporter)

Updated

4 years ago
Duplicate of this bug: 911007
(Reporter)

Updated

4 years ago
Severity: critical → normal
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Priority: P1 → P2
Resolution: --- → WORKSFORME
(Reporter)

Updated

4 years ago
Duplicate of this bug: 911057
Lecky,

If you feel your code would improve the functionality here, please supply your patch for review here to be included into the project :)

However, I feel we shouldn't have to block on this here as this is somewhat a corner case.
Status: RESOLVED → UNCONFIRMED
blocking-b2g: hd? → -
Resolution: WORKSFORME → ---

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.