[B2G][ Helix][gallery][yangshiqi] Gallery thumbnails don't disappear quickly enough when SD card is removed

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Gallery
P4
normal
RESOLVED WONTFIX
5 years ago
4 years ago

People

(Reporter: lecky, Unassigned, NeedInfo)

Tracking

({perf})

unspecified
1.4 S6 (25apr)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [c=progress p= s=2014.04.25 u=helix])

Attachments

(1 attachment)

114.90 KB, application/octet-stream
Details
(Reporter)

Description

5 years ago
Created attachment 797752 [details]
20130830172029801.rar

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E)

Steps to reproduce:

【Detail Description*】:The picture in gallery memoried in SD card will take a too long time to disappear when we take away the sd card and the number of picture in SD card is big . 
【Repro Steps*】:1.enter into gallery ,check the thumbnail picture.
                  2.take away the SD card,watch out the time which thumbnail picture disappeared. 
【Expect Result*】:the app which been sweep of was open
【Real Result*】:the icons display like to be chosen,but it has no actually touchpoint  
【Test Count*】:5
【Found Count*】:5
【Gaia commit ID*】:c0ea0a4943dc8d3751b07f5b5c5d3abe06364a14  
【Gecko commit ID*】: 170f9e477571127cd40997fa2abe262ed43f0e4d 
【Log*】:20130830172029801.rar
【Network environment】:
【Resume operation】:
【Carrier】:

Updated

5 years ago
Component: General → Gaia::Gallery
Keywords: perf
(Reporter)

Updated

5 years ago
Severity: normal → blocker
Priority: -- → P2
(Reporter)

Updated

5 years ago
blocking-b2g: --- → hd?

Comment 1

5 years ago
Can you define the acceptable response time and how many images you were testing with?
Flags: needinfo?(lecky.wanglei)
Whiteboard: [ c= p= u= s= ]
(Reporter)

Comment 2

5 years ago
(In reply to Ben Kelly [:bkelly] from comment #1)
> Can you define the acceptable response time and how many images you were
> testing with?

It was compared with android.So we think it may be do some optimization here
Flags: needinfo?(lecky.wanglei)
(Reporter)

Updated

5 years ago
blocking-b2g: hd? → ---
How many pictures were stored on the SD card to cause this? 

Also, can you update with more specific timing info regarding how long the unresponsive icons stuck around?
Severity: blocker → normal
Flags: needinfo?(lecky.wanglei)
Summary: [B2G][ Helix][gallery][yangshiqi]The picture in gallery memoried in SD card will take a too long time to disappear when we take away the sd card and the number of picture in SD card is big → [B2G][ Helix][gallery][yangshiqi] Gallery thumbnails don't disappear quickly enough when SD card is removed

Comment 4

4 years ago
Resolving as WONTFIX since many performance updates have been made since 1.1 and upgrading is the best path forward here.

FxOS Perf Prioritization: https://wiki.mozilla.org/FirefoxOS/Performance/Triage#Prioritization
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Priority: P2 → P4
Resolution: --- → WONTFIX
Whiteboard: [ c= p= u= s= ] → [c=progress p= s=2014.04.25 u=helix]

Updated

4 years ago
Target Milestone: --- → 1.4 S6 (25apr)
You need to log in before you can comment on or make changes to this bug.