Closed Bug 911164 Opened 7 years ago Closed 3 years ago

Current window loses focus temporarily when hovering the pointer over the QuickTime volume button

Categories

(Core :: Plug-ins, defect, P4)

x86
macOS
defect

Tracking

()

RESOLVED WONTFIX

People

(Reporter: bogdan_maris, Unassigned)

Details

Attachments

(2 files)

Reproducible on the latest Beta (BuildID: 20130829135643):
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:24.0) Gecko/20100101 Firefox/24.0
Reproducible on the latest Aurora (BuildID: 20130830004004):
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:25.0) Gecko/20100101 Firefox/25.0
Reproducible on the latest Nightly (BuildID: 20130829030201): 
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:26.0) Gecko/20100101 Firefox/26.0

Steps to reproduce:
1. Start Firefox.
2. Drag a .mp3 file in one tab.
3. Hover the pointer over the volume button.

Expected results: Focus stays on Firefox.

Actual results: Firefox loses focus when hovered over the volume button.

Notes:
1. Same issue with a H.264 encoded video.
This is a page using QuickTime that you see, not Firefox <audio> or <video>.
Component: Video/Audio → Plug-ins
Please attach an .mp3 file with which you can reproduce this problem.

> 1. Same issue with a H.264 encoded video.

Please attach another example for this testcase.

And what does this mean?  Does this testcase load a plugin (QuickTime or some other plugin)?

Finally, do these problems happen on all platforms (including Windows and Linux), or only on the Mac?
Attached audio .mp3 audio file sample
(In reply to Steven Michaud from comment #2)
> Please attach an .mp3 file with which you can reproduce this problem.

.mp3 file attached, though it`s reproducible with any .mp3 file.
 
> > 1. Same issue with a H.264 encoded video.
> 
> Please attach another example for this testcase.

I had a large file on my PC (+200MB) but I found one on the web:
http://www.808.dk/pics/video/gizmo.mp4

> And what does this mean?  Does this testcase load a plugin (QuickTime or
> some other plugin)?

Yes it loads a QuickTime plugin. 

> Finally, do these problems happen on all platforms (including Windows and
> Linux), or only on the Mac?

This happens only on Mac (10.7.3 and 10.8).
Also attached a screenshot showing the issue.
Thanks for the details. I can't be sure, but this really looks like an issue with how the Quicktime plugin does the volume popup.
Priority: -- → P4
I can reproduce this (in FF 23.0.1 on OS X 10.8.4).

You don't need to drag a file into a tab -- just visiting a URL like http://www.808.dk/pics/video/gizmo.mp4 will also allow you to reproduce the problem.

I see the same problem in Opera 16, but not in Safari.  So yes, this looks very much like a QuickTime bug.  I assume that Safari contains some kind of workaround (or that QuickTime behaves differently in Safari).

For some reason, QuickTime in Chrome uses a different UI for the volume button, so the problem can't happen there.
Summary: Firefox loses focus when hovering the pointer over the volume button → Firefox loses focus when hovering the pointer over the QuickTime volume button
Another couple of things:

It's not the app (Firefox or Opera) that loses focus -- it's the current window (the one in which the plugin is displayed).

And even that window only loses focus temporarily (only as long as the mouse hovers over the volume button).
Summary: Firefox loses focus when hovering the pointer over the QuickTime volume button → Current window loses focus temporarily when hovering the pointer over the QuickTime volume button
I'm marking this bug as WONTFIX per bug #1269807.

For more information see - https://blog.mozilla.org/futurereleases/2015/10/08/npapi-plugins-in-firefox/
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.