mach xpcshell-test: AttributeError: 'module' object has no attribute 'MIB_TCP_STATE_ESTAB'

RESOLVED DUPLICATE of bug 908296

Status

Testing
XPCShell Harness
--
blocker
RESOLVED DUPLICATE of bug 908296
4 years ago
4 years ago

People

(Reporter: mayhemer, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Just merged gum project tree with m-c, clobbered build:

$ mach xpcshell-test netwerk/test/unit --sequential

OR

$ mach xpcshell-test netwerk/test/unit

giving:

Error running mach:

    ['xpcshell-test', 'netwerk/test/unit', '--sequential']

The error occurred in code that was called by the mach command. This is either
a bug in the called code itself or in the way that mach is calling it.

You should consider filing a bug for this issue.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

AttributeError: 'module' object has no attribute 'MIB_TCP_STATE_ESTAB'

  File "c:\Mozilla\src\gum\testing/xpcshell/mach_commands.py", line 235, in run_xpcshell_test
    return xpcshell.run_test(**params)
  File "c:\Mozilla\src\gum\testing/xpcshell/mach_commands.py", line 105, in run_test
    return self._run_xpcshell_harness(**args)
  File "c:\Mozilla\src\gum\testing/xpcshell/mach_commands.py", line 114, in _run_xpcshell_harness
    import runxpcshelltests
  File "c:\Mozilla\src\gum\testing/xpcshell\runxpcshelltests.py", line 29, in <module>
    import psutil
  File "c:\Mozilla\src\gum\python/psutil\psutil\__init__.py", line 85, in <module>
    import psutil._psmswindows as _psplatform
  File "c:\Mozilla\src\gum\python/psutil\psutil\_psmswindows.py", line 56, in <module>
    _psutil_mswindows.MIB_TCP_STATE_ESTAB : CONN_ESTABLISHED,



Old way of running the tests:

$ SOLO_FILE="unit/test_bug770243.js" pymake -C _obj-browser-debug/netwerk/test/ check-one
make.py[0]: Entering directory 'c:\Mozilla\src\gum\_obj-browser-debug/netwerk/test/'
Please consider running xpcshell tests via mach: |mach xpcshell-test path/to/test|.
c:\Mozilla\src\gum\config\makefiles\xpcshell.mk:94:0$ c:/Mozilla/src/gum/_obj-browser-debug/_virtualenv/Scripts/python.exe -u c:/Mozilla/src/gum/config/python
path.py \
  -I../../build \
  -Ic:/Mozilla/src/gum/build \
      -I../../_tests/mozbase/mozinfo \
  c:/Mozilla/src/gum/testing/xpcshell/runxpcshelltests.py \
  --symbols-path=../../dist/crashreporter-symbols \
  --build-info-json=../../mozinfo.json \
  --test-path=unit/test_bug770243.js \
  --testing-modules-dir=../../_tests/modules \
  --profile-name=firefox \
  --test-plugin-path=../../dist/plugins \
  --verbose \
   \
  c:/Mozilla/src/gum/_obj-browser-debug/dist/bin/xpcshell \
  ../../_tests/xpcshell/netwerk/test/unit ../../_tests/xpcshell/netwerk/test/unit_ipc
Traceback (most recent call last):
  File "c:/Mozilla/src/gum/config/pythonpath.py", line 56, in <module>
    main(sys.argv[1:])
  File "c:/Mozilla/src/gum/config/pythonpath.py", line 48, in main
    execfile(script, frozenglobals)
  File "c:/Mozilla/src/gum/testing/xpcshell/runxpcshelltests.py", line 29, in <module>
    import psutil
  File "c:\Mozilla\src\gum\python\psutil\psutil\__init__.py", line 85, in <module>
    import psutil._psmswindows as _psplatform
  File "c:\Mozilla\src\gum\python\psutil\psutil\_psmswindows.py", line 56, in <module>
    _psutil_mswindows.MIB_TCP_STATE_ESTAB : CONN_ESTABLISHED,
AttributeError: 'module' object has no attribute 'MIB_TCP_STATE_ESTAB'
c:\Mozilla\src\gum\config\makefiles\xpcshell.mk:94:0: command 'c:/Mozilla/src/gum/_obj-browser-debug/_virtualenv/Scripts/python.exe -u c:/Mozilla/src/gum/conf
ig/pythonpath.py \
  -I../../build \
  -Ic:/Mozilla/src/gum/build \
      -I../../_tests/mozbase/mozinfo \
  c:/Mozilla/src/gum/testing/xpcshell/runxpcshelltests.py \
  --symbols-path=../../dist/crashreporter-symbols \
  --build-info-json=../../mozinfo.json \
  --test-path=unit/test_bug770243.js \
  --testing-modules-dir=../../_tests/modules \
  --profile-name=firefox \
  --test-plugin-path=../../dist/plugins \
  --verbose \
   \
  c:/Mozilla/src/gum/_obj-browser-debug/dist/bin/xpcshell \
  ../../_tests/xpcshell/netwerk/test/unit ../../_tests/xpcshell/netwerk/test/unit_ipc' failed, return code 1



Going to try with clean m-c, but I believe this is not specific to projects/gum.
(Reporter)

Comment 1

4 years ago
Grrr...

Dupe of 908296
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 908296
You need to log in before you can comment on or make changes to this bug.