crash in java.lang.IllegalArgumentException: Cannot handle null URLs in enterEditingMode at org.mozilla.gecko.BrowserApp.enterEditingMode(BrowserApp.java)

RESOLVED FIXED in Firefox 26

Status

()

--
critical
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: aaronmt, Assigned: lucasr)

Tracking

({crash})

Trunk
Firefox 26
All
Android
crash
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox25 unaffected, firefox26+ fixed, fennec26+)

Details

(Whiteboard: [native-crash][startupcrash], crash signature)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
This bug was filed from the Socorro interface and is 
report bp-c7427fef-91da-4930-9a35-513c52130827.
=============================================================
(Reporter)

Comment 3

6 years ago
Hey mcomella, regression from bug 905088?
Flags: needinfo?(michael.l.comella)
Short answer: yes.

Long answer: The patch from bug 905988 validates the url argument and throws an exception if it's null. We never use url without checking if it was null first within enterEditingMode(url), so we never ran into this with a NullPointerException before. The patch in bug 905988 makes the code safer so we should try to track down the cause of the null, rather than backing out the patch.

According to crash-stats, the crash seems to occur at boot so I'm guessing Tabs.getInstance().getSelectedTab() is returning null because the open tabs have not yet loaded. Perhaps if this is the case and the tab instance is null, we should pass the empty string to enterEditingMode(url) (but this should be researched further).
Flags: needinfo?(michael.l.comella)
(Reporter)

Updated

6 years ago
Blocks: 905088
tracking-fennec: --- → ?

Comment 5

5 years ago
Those are all within the first minute after launch and this is the #2 topcrash on 26.0a1 Nightly at this time.
status-firefox25: --- → unaffected
status-firefox26: --- → affected
tracking-firefox26: --- → ?
Keywords: topcrash
Whiteboard: [native-crash][startupcrash]
(Assignee)

Comment 6

5 years ago
Created attachment 799547 [details] [diff] [review]
Use empty URL if entering editing mode on startup with no tabs
Attachment #799547 - Flags: review?(michael.l.comella)
(Assignee)

Updated

5 years ago
Assignee: nobody → lucasr.at.mozilla
Comment on attachment 799547 [details] [diff] [review]
Use empty URL if entering editing mode on startup with no tabs

Review of attachment 799547 [details] [diff] [review]:
-----------------------------------------------------------------

r+, but you may want to add a javadoc comment to enterEditingMode(String) explaining what passing an empty string should do.
Attachment #799547 - Flags: review?(michael.l.comella) → review+
tracking-fennec: ? → 26+
(Assignee)

Comment 8

5 years ago
Pushed with the suggested changes: https://hg.mozilla.org/integration/fx-team/rev/1c7b17c72cfd
https://hg.mozilla.org/mozilla-central/rev/1c7b17c72cfd
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 26
status-firefox26: affected → fixed
tracking-firefox26: ? → +
Keywords: steps-wanted
Keywords: topcrash
(Reporter)

Updated

5 years ago
Duplicate of this bug: 927017
Depends on: 975837
You need to log in before you can comment on or make changes to this bug.