Closed Bug 911330 Opened 6 years ago Closed 6 years ago

[User Story] Quickly Enable Connectivity When Data Is Off and No WiFi Connection

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(feature-b2g:2.0)

VERIFIED FIXED
1.4 S4 (28mar)
feature-b2g 2.0

People

(Reporter: pdol, Unassigned)

References

Details

(Keywords: feature, Whiteboard: [ucid:System54, 1.4:P2, ft:systemsfe][systemsfe])

User Story:

As a user who has mobile data currently disabled, no active WiFi connection and Airplane mode is off, instead of being shown the blue offline screen, I should be made aware that my data connection is currently disabled and given a way to quickly enable a connection so that I don’t need to manually leave the app, open the settings (or utility tray), enable the connection and return to the app.


Acceptance Criteria:

1. If airplane mode is off and data is disabled (within Settings), in scenarios in which I would normally be shown the blue offline screen, I am informed that I have no active connection.
2. After I am informed that I have no active connection as in 1, I can enable data without needing to access the settings or utility tray.
3. After I am informed that I have no active connection as in 1, and WiFi is turned off, I can turn on WiFi without needing to access the settings or utility tray.
4. After I am informed that I have no active connection as in 1, and WiFi is turned on, I can access my WiFi connections without needing to access the settings.
5. If I chose to ignore the message received in 1, I am taken to the previous position in the app. (if one exists)
6. If I chose to ignore the message received in 1, and I am currently on the entry point within the app (ie. first screen), I am exited out of the app.
This should be fixed as a part of bug 882186.
Assignee: nobody → mhenretty
Depends on: 882186
Peter Dolanjski deleted the linked story in Pivotal Tracker
Ghislain 'Aus' Lacroix changed story state to started in Pivotal Tracker
Whiteboard: [ucid:System54] → [ucid:System54][systemsfe]
blocking-b2g: --- → 1.3+
We certainly want this in 1.3, but we won't block on it.
blocking-b2g: 1.3+ → -
Target Milestone: --- → 1.3 Sprint 3 - 10/25
Blocks: 930630
Target Milestone: 1.3 Sprint 3 - 10/25 → 1.3 Sprint 4 - 11/8
Duplicate of this bug: 935346
Flags: in-moztrap?(jsmith)
Whiteboard: [ucid:System54][systemsfe] → [ucid:System54][systemsfe][1.3:p2]
Whiteboard: [ucid:System54][systemsfe][1.3:p2] → [ucid:System54][systemsfe]
Fixed per landing of the dependent bug
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Actually they aren't - checked with mhenretty that this isn't fully fixed by bug 882186.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
No longer blocks: 1.3-systems-fe
Flags: in-moztrap?(jsmith) → in-moztrap?
Whiteboard: [ucid:System54][systemsfe] → [ucid:System54, 1.4:P2, ft:systemsfe]
Taking myself off this for now, as I might not be the one to work on it after all.
Assignee: mhenretty → administration
Flags: in-moztrap? → in-moztrap?(rafael.marquez)
Depends on: 969267
Whiteboard: [ucid:System54, 1.4:P2, ft:systemsfe] → [ucid:System54, 1.4:P2, ft:systemsfe][systemsfe]
Target Milestone: 1.3 Sprint 4 - 11/8 → 1.4 S2 (28feb)
blocking-b2g: - → 1.4?
blocking-b2g: 1.4? → ---
Target Milestone: 1.4 S2 (28feb) → 1.4 S3 (14mar)
Target Milestone: 1.4 S3 (14mar) → 1.4 S4 (28mar)
closing as latest bug 969267 is finished
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
QA Contact: rafael.marquez
Verified in master v1.5 branch
Status: RESOLVED → VERIFIED
feature-b2g: --- → 2.0
You need to log in before you can comment on or make changes to this bug.