If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Buri][fugu][Language][Email]The "view the attachment" Button is truncated.

VERIFIED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia::E-Mail
P2
normal
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: sync-1, Assigned: psingapati)

Tracking

unspecified
2.0 S5 (4july)

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified)

Details

(Whiteboard: [LibGLA,TD53941,WW,B] )

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
Firefox os  v1.1
  Mozilla build ID:20130826041201
 
 Created an attachment (id=505337)
 PIC1
 
 DEFECT DESCRIPTION:
 Button to view the attachment shows is not perfect in Hungarian
 REPRODUCING PROCEDURES: 
 1.Create an email account and have a mail with attchment in inbox
 2.Go to Settings->Language->Hungarian->OK->press center key
 3.Enter mail list,download the attchment,you will find Button to view the attachment shows is not perfect-->ko
 
 comments: Have the same problem in Czech,German,Polish,Greek and Serbian.
 
 EXPECTED BEHAVIOUR:
 It will display properly
 ASSOCIATE SPECIFICATION:
 
 TEST PLAN REFERENCE:
 
 TOOLS AND PLATFORMS USED:
 
 USER IMPACT:
 mid
 REPRODUCING RATE:
 5/5
 For FT PR, Please list reference mobile's behavior:
(Reporter)

Comment 1

4 years ago
Clone from brother
(Reporter)

Comment 2

4 years ago
Created attachment 798122 [details]
PIC1
Summary: [Buri][Language][Email]The "view the attachment" Button is truncated. → [Buri][fugu][Language][Email]The "view the attachment" Button is truncated.

Updated

4 years ago
Flags: needinfo?(tzhuang)
Flags: needinfo?(ehung)

Updated

4 years ago
blocking-b2g: --- → fugu?

Updated

4 years ago
blocking-b2g: fugu? → ---
CSS and string issue. Since it's not on fugu's priority, I will leave it to email devs for a proper fix. (cc James Burke)
Flags: needinfo?(ehung)
since Evelyn had a comment for it, clear ni flag.
Flags: needinfo?(tzhuang)
(Assignee)

Comment 5

3 years ago
Its better to have icon instead of "view" text for the attachments that were downloaded.
Please give your opinion and do the needful.

Thanks.
Flags: needinfo?(jrburke)
Asking UX for an icon for this button. Context for UX:

In message reader, after downloading an attachment, right now we just show a colored div with the text "View" inside of it. This causes problems for localizations. Is there an image we could use instead?

Ideally we can get an icon in, and then include this only as part of the 2.0 visual refresh (and I would ask for 2.0? in that case once I have the icon an a fix prepped).
Flags: needinfo?(jrburke) → needinfo?(jhuang)

Comment 7

3 years ago
It indeed a serious issue. I'll sync with Fang to see if we can solve it by providing an icon.
Flags: needinfo?(jhuang) → needinfo?(fshih)

Comment 8

3 years ago
Created attachment 8445055 [details]
view_icon.zip

According to the discussion with Juwei, we've decided to use the icon instead of text "view". Attached is the view icon. Thanks! : )
Flags: needinfo?(fshih)
(Assignee)

Updated

3 years ago
Assignee: nobody → psingapati
(Assignee)

Comment 9

3 years ago
Created attachment 8445694 [details]
Pointer to PR

Added view button that is provided from UX and adjusted positions in-line with download icon

Please review
Attachment #8445694 - Flags: review?(jrburke)
Comment on attachment 8445694 [details]
Pointer to PR

Thanks for jumping into this one. I just have a couple of small things in the pull request. Once those are addressed, flip review back to me, and I should then be able to merge pretty easily.
Attachment #8445694 - Flags: review?(jrburke)
(Assignee)

Comment 11

3 years ago
Comment on attachment 8445694 [details]
Pointer to PR

PR is updated as per the comments, Please check.
Thanks.
Attachment #8445694 - Flags: review?(jrburke)
Comment on attachment 8445694 [details]
Pointer to PR

Looks good. One small nit: `font-size: 0;` should be enough, no need to add rem units to it.

It also looks like state of master for the this pull request changed, so if you can remove the rem from the font size and rebase/squash on top of latest master, then I am happy to merge this change in to master.
Attachment #8445694 - Flags: review?(jrburke) → review+
(Assignee)

Comment 13

3 years ago
Updated PR with the change and rebased with master.

Please check now.
Thanks.
Flags: needinfo?(jrburke)
GitHub thought there was something wrong with the pull request as far as being able to merge, so it did not allow me to merge via the UI. So I created a new pull request and cherry-picked :psingapati's commit in that pull request, and that merges.

So fixed on master:
https://github.com/mozilla-b2g/gaia/commit/6848631d1fe8baf973e3d1257f7b50427295477b

from pull request:
https://github.com/mozilla-b2g/gaia/pull/21297

Also asking for 2.0+ since I consider this as part of the visual refresh changes. There are no l10n string changes so it should be safe to uplift.
Status: NEW → RESOLVED
blocking-b2g: --- → 2.0?
Last Resolved: 3 years ago
Flags: needinfo?(jrburke)
Resolution: --- → FIXED

Updated

3 years ago
blocking-b2g: 2.0? → 2.0+
v2.0: https://github.com/mozilla-b2g/gaia/commit/d855997f795c7ca7d2d2e5882eefd270c7772540
status-b2g-v2.0: --- → fixed
status-b2g-v2.1: --- → fixed
Target Milestone: --- → 2.0 S5 (4july)
(Assignee)

Updated

3 years ago
Whiteboard: [LibGLA,TD53941,WW,B]
Hi,
    This issue has been successfully verified on Flame 2.1,and we select Polish\Magyar\Czech\German language.
    See attachment: verified_v2.1.MP4.
    Reproducing rate: 0/4

Flame 2.1 build:
Gaia-Rev        1bdd49770e2cb7a7321e6202c9bf036ab5d8f200
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/db893274d9a6
Build-ID        20141125001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141125.040617
FW-Date         Tue Nov 25 04:06:28 EST 2014
Bootloader      L1TC00011880
status-b2g-v2.1: fixed → verified
Created attachment 8528960 [details]
verified_v2.1.mp4
 Hi,
    This issue has been successfully verified on Flame 2.0.
    Reproducing rate: 0/4

Flame 2.0 build:
Gaia-Rev        f9d6e3d83c3922e9399a6c27f5ce4cdd27bdfd05
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/45112935086f
Build-ID        20141126000203
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141126.032754
FW-Date         Wed Nov 26 03:28:05 EST 2014
Bootloader      L1TC00011880
Status: RESOLVED → VERIFIED
status-b2g-v2.0: fixed → verified
You need to log in before you can comment on or make changes to this bug.