Add YCbCr_420_SP_TILED's color conversion to android::ColorConverter in nexus4

RESOLVED DUPLICATE of bug 911548

Status

Firefox OS
General
RESOLVED DUPLICATE of bug 911548
4 years ago
4 years ago

People

(Reporter: sotaro, Assigned: sotaro)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

4 years ago
For nexus4's build android JB' AOSP source is used. But the AOSP's default android::ColorConverter do not support color conversion from HAL_PIXEL_FORMAT_YCbCr_420_SP_TILED(0x7FA30C03) to RGB 565. Without the conversion, video frame can not draw to canvas and video app can not generate video's thumbnail. Need to add the color conversion.
(Assignee)

Updated

4 years ago
Blocks: 871364
(Assignee)

Updated

4 years ago
Assignee: nobody → sotaro.ikeda.g
(Assignee)

Comment 1

4 years ago
In qcom's hw, the color conversion is normally done by "libmm-color-convertor.so". The rom include the library. So, the conversion should be possible.
(Assignee)

Comment 2

4 years ago
codeaurora's source support the conversion. By applying the related part to aosp's srouce, the conversion might be possible in nexus-4.
https://www.codeaurora.org/cgit/external/simcom/platform/frameworks/av/tree/media/libstagefright/colorconversion/ColorConverter.cpp?h=jb-8930-master-dsda
(Assignee)

Comment 3

4 years ago
Created a rom applying the change in comment #2. But failed to load a function in the following. nuxus4's related function seems different.

> convertFn convertNV12Tile = (convertFn)dlsym(lib, "_ZN7android7convertENS_18ColorConvertParamsES0_Ph");
(Assignee)

Comment 4

4 years ago
Checked the function's symbol name by using following command.
> nm -D ./libmm-color-convertor.so
(Assignee)

Comment 5

4 years ago
Created attachment 798241 [details] [diff] [review]
patch - Add a color format support to android::ColorConverter

Confirmed the thumnail generation in video app. To confirm it, I did following.
- Apply attachment 798240 [details] [diff] [review] in Bug 871364.
- Create directory by Bug 910498 Comment 18
- push h.264 video to nexus 4
(Assignee)

Updated

4 years ago
blocking-b2g: --- → koi?
(Assignee)

Updated

4 years ago
Blocks: 784227
(Assignee)

Updated

4 years ago
No longer blocks: 871364
Depends on: 871364
(Assignee)

Comment 6

4 years ago
Created attachment 798527 [details] [diff] [review]
patch v2 - Add a color format support to android::ColorConverter

Add Code Aurora Forum's copyright.
Attachment #798241 - Attachment is obsolete: true
(Assignee)

Comment 7

4 years ago
mwu, does "nexus-4 build" continue to use aosp? not caf?
Flags: needinfo?(mwu)

Comment 8

4 years ago
Nexus 4 is currently on AOSP, but it may change to CAF if we start making builds for it.
Flags: needinfo?(mwu)
(Assignee)

Comment 9

4 years ago
Merge the patch to Bug 911548.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 911548

Updated

4 years ago
blocking-b2g: koi? → ---
You need to log in before you can comment on or make changes to this bug.