If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Fetching a non-public bug via XML fails due to TrackingFlags extension

RESOLVED FIXED

Status

()

bugzilla.mozilla.org
Extensions: TrackingFlags
--
major
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: wicked, Assigned: glob)

Tracking

Production

Details

(URL)

(Reporter)

Description

4 years ago
When fetching bugs as XML, the fetch sometimes fails with this error embedded in the returned HTML*:

Bugzilla has suffered an internal error:
<code>component</code> is not a valid parameter for the Bugzilla::Extension::TrackingFlags::Flag::match function.

At the moment this happens with bug 907438 when the user is logged out. Doesn't seem to happen when I login but that's not an option for poor bugbot that's suffering due to this.

*Yes, full error HTML page returned with "Content-Type: application/xml; charset=UTF-8" response header.
(Assignee)

Updated

4 years ago
Assignee: nobody → glob
Severity: normal → major
(Assignee)

Comment 1

4 years ago
Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bmo/4.2/
modified extensions/TrackingFlags/Extension.pm
Committed revision 8977.

> Yes, full error HTML page returned with "Content-Type: application/xml; charset=UTF-8" response header.

that happens if you call ThrowCodeError after the cgi header is printed (eg, when triggered via a template hook).  can you raise an upstream bug for that?
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Summary: Fetching a bug as XML sometimes fails due to TrackingFlags extension → Fetching a non-public bug via XML fails due to TrackingFlags extension
You need to log in before you can comment on or make changes to this bug.