The default bug view has changed. See this FAQ.

file:///link on webpage does not work

VERIFIED DUPLICATE of bug 84128

Status

()

Core
Security
--
major
VERIFIED DUPLICATE of bug 84128
16 years ago
16 years ago

People

(Reporter: beanladen, Assigned: dougt)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
x86 Linux 2.4.6 gcc2.95 XFree86 4.0.3 and Solaris 8 any builds

A link file:///path/file.html on a webpage loaded via http does not
work, although I'm on that local machine and have access rights
to that file. The same file link entered into the url bar works.
This is inconsistent and overly restrictive (I know that this was
intentionally built in as an security feature, but it should not
prevent the user from looking at his own files !). This is a very 
often used construction in web pages to have local access to locally 
stored documentation and works with all Netscape releases.
By the way, when loading the webpage via file:///..., the links
to local files on that page work...

Expected: Mozilla should check if local access rights apply
          (as it does in the url bar) and should load the
          pages accordingly. It should deny loading if access
          rights do not apply.

Comment 1

16 years ago
I believe the pref "security.checkloaduri" can disable this globally. bug 40538
should have all the details.

*** This bug has been marked as a duplicate of 40538 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
REOPEN:
Lets use bug 84128, otherwise this is actually invalid b/c its supposed to fail
to load.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
as benc requests, this is a dupe of bug 84128


*** This bug has been marked as a duplicate of 84128 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
VERIFIED:
same problem.
Status: RESOLVED → VERIFIED

Comment 5

16 years ago
moving comp & qa to sec:gen.
Component: Networking: File → Security: General
QA Contact: tever → bsharma
You need to log in before you can comment on or make changes to this bug.