"Skype Click To Call" add-on has a bad memory leak (lots of detached windows)

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: SCNordin, Unassigned)

Tracking

23 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [MemShrink:P3][3rd-party-bustage])

Attachments

(1 attachment)

245.04 KB, application/octet-stream
Details
(Reporter)

Description

5 years ago
Created attachment 798398 [details]
memory-report.json.gz

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130814063812

Steps to reproduce:

Start Firefox fresh in a Windows XP environment with SP3 from the task-bar.
Open a window with multiple tabs(my personal experience showed the tab didn't matter but for this test I opened the URL's including http://www.foxnews.com/ http://www.reuters.com/ http://en.rian.ru/ http://www.prequeladventure.com/ and a random Google images search with the keyword 'hats'. After approximately 2 hours of browsing and such, I put my computer into hibernate mode. I then re-opened my computer, re-established the internet connection and then began to open a test private window.


Actual results:

After some more browsing, the usage of memory grew to 1Gb and after another hour of usage, the hangs began and CPU usage would spike to about 50% and the memory would grow by about 200Kb per second for about 30 seconds and then it would reduce back down to a usable level and cpu usage would lower down to about 15%. This would repeat between every 1-4 minutes.


Expected results:

Firefox should have easily handled the new tabs and the hibernation without the hanging or other problems that occurred and the memory usage shouldn't have gotten up to 1Gb with only 7 tabs open.

Comment 1

5 years ago
Did you test with a clean profile and no add-ons?
Flags: needinfo?(SCNordin)
Whiteboard: [MemShrink]
Past history suggests it's quite likely that an add-on is at fault.  Do you have add-ons installed, and if so, can you list them?  (They're listed in about:support.)

[MemShrink:P3 until we get a better idea of whether it is an add-on at fault.]
Whiteboard: [MemShrink] → [MemShrink:P3]
(Reporter)

Comment 3

5 years ago
To reply to those that have commented before, I tried to replicate the results with a clean boot and no add-ons and couldn't manage to get the same result, therefore supporting the theory that this is associated with an add-on or two. The folowing is a list of add-ons that I currently have installed:
Adblock Plus2.3.2true{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
HTTPS-Everywhere3.4.1truehttps-everywhere@eff.org
McAfee SiteAdvisor3.6.2true{4ED1F68A-5463-4931-9384-8FFF5ED91D92}
Skype Click to Call6.11.0.13348true{82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}
Microsoft .NET Framework Assistant0.0.0false{20a82645-c095-46ed-80e3-08825760534b}

I am curious which of these are causing the error because I have tried to run with only selective add-ons active but if you are aware of any of these having major problems like this, please let me know.
Flags: needinfo?(SCNordin)
Adblock Plus is very reliable.  Don't know about HTTPS-Everywhere.

But I bet it's either McAfee SiteAdvisor or the Skype one.  Both of those add-ons (or similarly named ones) have caused major problems in the past.
(Reporter)

Comment 5

5 years ago
I have found out that the problem was the Skype Click to Call. I am not the best with code or anything so I can't determine if it is on the app's end or part of Firefox acting up with the app but I removed it and everything is running smoothly now. Thanks for the help and I hope that all will be running smoothly for you all in the future.
Can we replicate this bad leak in Skype Click to Call, and if so, contact them about it?
Summary: Firefox after extended usage and opening of multiple tabs causes hangs and jumps of memory usage up to 1.5Gb. → "Skype Click To Call" add-on has a bad memory leak (lots of detached windows)
It's hard to try to reproduce without more detailed instructions, or at least an about:memory dump. The extension is almost entirely a binary component, so I can't look at the code, and I don't run Windows, so I can't just leave it installed and wait.
Oh, completely missed the attachment
Yeah, it looks like it's creating immortal zombie compartments for every content window ever created.

Jorge, can you try to contact Skype about this? I think this is a blockworthy offense.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [MemShrink:P3] → [MemShrink:P3][3rd-party-bustage]
Flags: needinfo?(jorge)
(Reporter)

Comment 10

5 years ago
I hope the information that I provided has helped you all in stopping this problem. Is there any other information that I can provide that would help you in dealing with this issue?
I'm looking for contact information now.
Flags: needinfo?(jorge)

Comment 12

5 years ago
This issue has been fixed in version 7.0 of the Skype Click to Call plugin.
Calling this WFM. Please reopen if the problem persists.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.