Graphics scaling algorithm gets lost

RESOLVED DUPLICATE of bug 849590

Status

()

defect
RESOLVED DUPLICATE of bug 849590
6 years ago
6 years ago

People

(Reporter: dimitrisdad, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(2 attachments)

Reporter

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130807125118

Steps to reproduce:

<img> tag causes firefox to render graphic, but it does so incorrectly.


Actual results:

.jpg graphic on website gets reduced to be rendered, but the algortihm adds a long bar to the left, so the graphic renders truncated and shifted to the right.

In prior versions of firefox before 23 the graphic rendered shuffled in pieces.  The shuffling problem was reported and confirmed as a bug in 2009, but remained unfixed.  Now in version 23 it has changed in nature, so I'm filing on it again.


Expected results:

the graphic should have rendered as it normally does, but smaller.

I have created a test page where this can be seen:
www.itio-a-child.org/test.php
Reporter

Updated

6 years ago

Comment 1

6 years ago
You have already reported an issue here with the same website: bug 849590

Is it the same issue? If yes, dupe it.
If not, provide a reduced testcase as you know the procedure.
Flags: needinfo?(dimitrisdad)

Updated

6 years ago
Component: Untriaged → ImageLib
Product: Firefox → Core
Reporter

Comment 2

6 years ago
As noted in the report above, it may be related to the bug that has remained unfixed for four years as reported in 849590,  but the behavior is different now with version 23.  Over the past four years firefox has shuffled the image when scaling it (though other browsers had no problems with it).  Now Firefox does something different, instead it adds a bar to the left. I suspect the two are related, but I have no way to know if they are.

As noted in the report above, the reduced test case can be found at www.itio-a-child.org/test.php

BTW, excuse me, it is a .gif  not .jpeg.
Flags: needinfo?(dimitrisdad)

Comment 3

6 years ago
4 years? I have some doubts about this statement. FF17 released in Nov. 2012 renders the website the same way as IE9, including the reduced testcase I attached to bug 849590. The 1st regression appeared in FF19 (bug 849590) and now there is maybe a new one. Anyway, we need a reduced testcase built from the one I attached in the previous bug.
Maybe some CSS stuff are involved.
(In reply to Thomas from comment #2)
> Now
> Firefox does something different, instead it adds a bar to the left.

Please provide a testcase for that issue.
Flags: needinfo?(dimitrisdad)
Reporter

Comment 5

6 years ago
As it says in the header above:  URL:	 http://www.itio-a-child.org/test.php (edit)   .. and I just checked it, and it still does it.

funny the reporting date on this go around was March, now it reads September https://bugzilla.mozilla.org/show_bug.cgi?id=849590

and yes, looking in my old email, the original report for this graphic shuffling (that was the original behavior) was October 2010, so this is over three years, but not yet four years.  Apparently it was confirmed but shelved because someone said there was a workaround.  

No matter, the .png looks fine - I really have to thank the person who suggested that.
Flags: needinfo?(dimitrisdad)
Reporter

Comment 8

6 years ago
I have added screen shot attachments showing fire fox messing up when it scales the .giff image, and google chrome doing fine. 

Gosh, I'm a little surprised that this bug has caused so little interest as scaling gifs is a common and important function.  But if you all want to ignore it, fine by me as we are using .png now.  I'll tell the guys that .gif is no longer supported.  (well actually already did).
Reporter

Comment 9

6 years ago
BTW,  the screenshot just included was taken on Firefox 25.0 over Fedora 19.
Confirmed with Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131119030202 CSet: ba9ecdea3a90.

FWIW, with image.high_quality_downscaling.enabled;false there's no Issue.
Blocks: 486918
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: x86_64 → All
Version: 23 Branch → Trunk

Comment 11

6 years ago
(In reply to Thomas from comment #8)
> Gosh, I'm a little surprised that this bug has caused so little interest as
> scaling gifs is a common and important function.  But if you all want to
> ignore it, fine by me as we are using .png now.  I'll tell the guys that
> .gif is no longer supported.  (well actually already did).

The problem is with the GIF you're using, not all GIFs in general.

I.e. huge GIFs like
http://www.bluepie.com.au/thejudes/images/logokit/The-Judes-Logo-Print-300.gif
http://i149.photobucket.com/albums/s76/aezakmi42/maptrans-back-1.gif
http://mikegoulian.com/wp-content/uploads/2013/09/MG_Goodyear.gif
are all scaling fine.

So something in your GIF is throwing the scaler off.
Reporter

Comment 12

6 years ago
You know that is flawed logic...  We could have, for example, for the 500 million dollar Pentium divide bug, simply have said that divide works fine except for Dr. Nicely's numbers, so we are going to leave the divider broken.  (just don't divide with those numbers.)  In fact that logic would work for all bugs - just don't view pages with those cases.

The fact a person can show a legal gif not scaling is an existential proof that there is a class of images for which the scaling program is broken - and the fact this example has existed for some years now shows that Mozilla is not committed to supporting gifs in general - but only for specific gifs for which there are not problems - unfortunately the person browsing a site doesn't pick the images to be rendered.

The argument that there are work arounds and therefore it is OK to dismiss the bug, which has been done twice now, is equally flawed, as the person using the browser does not have the option or rewriting the website he or she is browsing.

That you would show me three gifs and say 'see our program works' even though there is a forth gif that doesn't work as a professional programmer and manager simply blows me mind and tarnishes my opinion of this organization.

All very strange.  Anyway, I'm stepping out of the discussion from here out as the test case is pretty clear.  No need to wave hands and explain why broken is OK, as I don't buy it and it takes your time as well.

Comment 13

6 years ago
Nobody said it's OK.

Comment 14

6 years ago
It's a dupe of bug 849590.

Take the testcase https://bug849590.bugzilla.mozilla.org/attachment.cgi?id=723196 and add the style "background-color:blue;" to the <body> and you will see the left bar.
It's just a side-effect artifact of the image scaling algo, but the main issue is described in bug 849590.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 849590
You need to log in before you can comment on or make changes to this bug.