Closed Bug 911968 Opened 9 years ago Closed 7 years ago

[HD]Center rotation point of refresh icon off

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect, P2)

All
Other
defect

Tracking

(b2g-v1.1hd affected)

RESOLVED FIXED
Tracking Status
b2g-v1.1hd --- affected

People

(Reporter: epang, Assigned: pivanov)

References

Details

(Whiteboard: helix, visual design, visual-tracking, jian)

Attachments

(8 files)

Pavel, when the refresh icon is pressed in the email app the center point seems to be off.  It rotates a bit wobbly.  Can you check the center rotation point? See the video i've attached.

This only occurs in HD.
Wayne, I marked as HD+ since this only occurs in HD.  If you can make it + that would be great! Thanks
Flags: needinfo?(wchang)
Required for HD correctness
blocking-b2g: hd? → hd+
Flags: needinfo?(wchang)
Attached image refresh@1.5x.png
Hey Eric,
because we rotate the image and the dimensions of the image are 45x45 px for HD the center is 22.5px so ... the circle of the icon need to be centered there but we can't do this :) that's why I made 46x46 px icon and I just resize the circle to 34px diameter (even number) but the image need to be created from some vector image, can you do this for me :)?
Attachment #803711 - Flags: feedback?(epang)
Flags: needinfo?(epang)
Attached image refresh@1.5x.png
Attached! :)

Let me know if I need to make any tweaks to it.
Flags: needinfo?(epang)
Attached file patch for Gaia/master
Attachment #804237 - Flags: review?(sjochimek)
Comment on attachment 804237 [details]
patch for Gaia/master

As this is a patch for master,
Pavel: Can you provide update for all refresh.png version ?
Thanks.
Attachment #804237 - Flags: review?(sjochimek)
Hey Eric,
can you provide the rest of the refresh.png images for all resolutions (SD and x2.0)?
Flags: needinfo?(epang)
Attached file Refresh Icons.zip
Hey Pavel, here is the icon at sd and 2x.  Let me know if there's anything else that's needed :)
Flags: needinfo?(epang)
Attachment #804237 - Flags: review?(sjochimek)
Comment on attachment 803711 [details]
refresh@1.5x.png

The icon looks good to me :)
Attachment #803711 - Flags: feedback?(epang) → feedback+
Is it normal that the icons are differents ?
Icons(@1x & @2x) should not be all like @1.5x icon ?
Flags: needinfo?(pivanov)
Flags: needinfo?(epang)
(In reply to Sam Joch [:samjoch] from comment #10)
> Is it normal that the icons are differents ?
> Icons(@1x & @2x) should not be all like @1.5x icon ?

Thanks Sam, yes they should be all the same.  Pavel do you need me to provide assets?
Flags: needinfo?(epang)
Hey Eric,
I updated the 1.5x version ... is this ok now?
Flags: needinfo?(pivanov) → needinfo?(epang)
(In reply to Pavel Ivanov [:ivanovpavel] from comment #12)
> Hey Eric,
> I updated the 1.5x version ... is this ok now?

yes, as long as they are all the same :).  Thanks!
Flags: needinfo?(epang)
Hey Sam :) now it's ready :)
Flags: needinfo?(sjochimek)
Sam, Pavel, who will finish this bug off? :)
Flags: needinfo?(pivanov)
I need r+ from someone ... I will try to find someone who can review the patch.
Flags: needinfo?(pivanov)
Attachment #804237 - Flags: review?(sjochimek) → review?(jrburke)
Comment on attachment 804237 [details]
patch for Gaia/master

I do not have a hidpi device to test this on, but given that is it just an image swap and looks good when viewed in the diff, r+
Attachment #804237 - Flags: review?(jrburke) → review+
Landed to master:
https://github.com/mozilla-b2g/gaia/commit/354f3b8d686427a198a2f1ea7691bdfc62c80ddd

Landed to v1.1.0hd:
4de25ada0decb3b994f7d6916e1eb99ef6e01912
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Duplicate of this bug: 936844
Flags: needinfo?(sjochimek)
I still can reproduce this bug on V1.1.0hd and Central(V1.3) after the patch landed.
Attaching the video. Thanks.

* Test Build:
 + V1.1.0hd
 - Gaia:     ff5fdef17c997deb000c386c809dbf2617656c9b
 - Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18_v1_1_0_hd/rev/42e2dbb0d538
 - BuildID   20131121042202
 - Version   18.0
 => Can reproduce

 + Central (V1.3)
  - Gaia:     c26480b22ce28c812c347290dd4bad090d83db6f
  - Gecko:    http://hg.mozilla.org/mozilla-central/rev/597287004ff5
  - BuildID   20131120062258
  - Version   28.0a1
  => Can reproduce
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Pavel,
Can you correct this?

Looking at closing off by 11/28.
Flags: needinfo?(pivanov)
After comment 20 modifying 1.1hd flag to Affected. Please feel free to modify it if I am wrong.
(In reply to Beatriz Rodríguez [:brg] from comment #23)
> After comment 20 modifying 1.1hd flag to Affected. Please feel free to
> modify it if I am wrong.

Hey Pavel I'm going to add this to out blocking the 1.3 refresh.  We need this fixed in in both HD and master.
Whiteboard: helix vsd → helix, visual design, visual-tracking, jian
Attached file patch for Gaia/master
Hey Eric,
this one need to be tested on HD device, can you do that for me? Thanks :)
Attachment #8341571 - Flags: feedback?(epang)
Flags: needinfo?(pivanov)
(In reply to Pavel Ivanov [:ivanovpavel] from comment #25)
> Created attachment 8341571 [details] [review]
> patch for Gaia/master
> 
> Hey Eric,
> this one need to be tested on HD device, can you do that for me? Thanks :)

Hey Pavel, it looks good on master now, but it's still incorrect on WVGA.  Let me know if there's anything I can do to help :). Thanks!
Flags: needinfo?(pivanov)
Hi Eric/Pavel,
We'll need this landed on v1.1HD as soon as possible (in the next day or two if possible), we're wrapping that branch up ;)
Attached video video
Attachment #8341641 - Flags: feedback?(epang)
Flags: needinfo?(pivanov)
Comment on attachment 8341641 [details]
video

Looks good, thanks Pavel.  Wayne can you help review so we can land? thanks!
Attachment #8341641 - Flags: feedback?(epang) → feedback+
Attachment #8341571 - Flags: feedback?(epang)
Attachment #8341571 - Flags: review?(wchang)
Comment on attachment 8341571 [details] [review]
patch for Gaia/master

looks like good to me. Thanks!
Attachment #8341571 - Flags: review?(wchang) → review+
merged into gaia master: https://github.com/mozilla-b2g/gaia/commit/c061ad61abd64f050c48805b27baf047e90bf084
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
(In reply to Evelyn Hung [:evelyn] from comment #31)
> merged into gaia master:
> https://github.com/mozilla-b2g/gaia/commit/
> c061ad61abd64f050c48805b27baf047e90bf084

Thanks Evelyn!
The icon looks good on master build. We still need your help to uplift this patch to V1.1.0hd because this is hd+ bug.
Thanks!


* Test Build:
 - Gaia:     6415b8b44068596404c10365394544e94edd5ce5
 - Gecko:    http://hg.mozilla.org/mozilla-central/rev/12ea03a70243
 - BuildID   20131211040203
 - Version   29.0a1
Could I have your help to uplift this patch to V1.1.0hd?
Thanks!
This is hd+ bug. Please uplift this patch to V1.1.0hd.
Thanks!
John, can you please assist? :)
Flags: needinfo?(jhford)
Hey guys,

We land the new [BB]Tabs few days ago and I have a fix for this bug too (the problem was bigger than I thought) I will try to create a patch tomorrow
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Flags: needinfo?(jhford)
Any update?
Thanks!
Mass-modify - removal of no longer relevant blocking flags
blocking-b2g: hd+ → ---
It looks like this bug was landed in master, but was only reopened to track uplift status. It does not seem relevant anymore, so I am going to mark as resolved again.
Status: REOPENED → RESOLVED
Closed: 8 years ago7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.