Closed Bug 911975 Opened 8 years ago Closed 4 years ago

small scroll jank on usharani.com, maybe due to custom font and/or text-shadow

Categories

(Core :: Graphics, defect)

26 Branch
x86_64
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: fb+mozdev, Unassigned)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [parity-chrome])

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20130902030220

Steps to reproduce:

1. visit http://www.usharani.com/pages/bio.html
2. scroll all the way to the bottom (I can only see the last four paragraphs in my case)
3. quickly scroll to the top, a quick sweep over my MBA trackpad was enough


Actual results:

Jank when the header appears. 


Expected results:

No jank. Tested it in Chrome, is smooth there. 

Both Logo and Menu have a text-shadow and use a custom font, though the menu has the same font as the text. So I suspect either the shadow, or the Logo's font to be the culprit for the jank (maybe a lack of font caching – graphics-wise?). 


Graphics: 
Device ID	0x 166
GPU Accelerated Windows	1/1 OpenGL (OMTC)
Vendor ID	0x8086
WebGL Renderer	Intel Inc. -- Intel HD Graphics 4000 OpenGL Engine
windowLayerManagerRemote	true
AzureCanvasBackend	quartz
AzureContentBackend	quartz
AzureFallbackCanvasBackend	none
AzureSkiaAccelerated	0


Nightly is pretty vanilla, just updated to test this issue. Beta 24 and Aurora have the exact same behaviour.
Hardware: x86 → x86_64
Whiteboard: [parity-chrome]
Blocks: 100951
Component: Untriaged → Graphics
Product: Firefox → Core
Blocks: 527728
Confirmed if using the autoscrolling, back from the bottom to the top on FF 27.0a1 2013-10-13, Mac OS X 10.8.4
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: small scroll jank on usharani.com, likely due to custom font and/or text-shadow → small scroll jank on usharani.com, maybe due to custom font and/or text-shadow
Not reproducible anymore.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.