Closed Bug 912012 Opened 9 years ago Closed 6 years ago

[Messages] we can trigger 2 navigation requests in the same time

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect, P3)

x86_64
Linux
defect

Tracking

(tracking-b2g:backlog, b2g-master affected)

RESOLVED DUPLICATE of bug 1218374
tracking-b2g backlog
Tracking Status
b2g-master --- affected

People

(Reporter: julienw, Unassigned)

References

Details

(Whiteboard: [sms-papercuts])

STR:
* have a big sms thread
* tap on it to load it
* immediately tap on the "start new message" icon
=> we move to the "new message" panel, but the sms thread is loading under it.

We should probably forbid any interaction while we're navigating.

I'd like to take this bug as an opportunity to introduce a new Navigation object that would handle all the navigation inside the SMS app.
Julien, we had an old bug that we could rescue for this purpose. It's https://bugzilla.mozilla.org/show_bug.cgi?id=881469, and there we were talking about the need of adding a 'Navigation' object for handling the navigation. I would like to move forward with this, Wdyt about defining the requirements that we want to accomplish in the other bug,I will create the tests first, and then I'll implement the code. Does it sounds good?
Flags: needinfo?(felash)
Depends on: 881469
You're right, the navigation object is bug 881469. I commented there :)

Lets keep this bug open as we might need to do something more here.
Flags: needinfo?(felash)
add to backlog bug 891754
blocking-b2g: koi? → ---
blocking-b2g: --- → backlog
blocking-b2g: backlog → ---
QAWANTED to see if this still happens
Keywords: qawanted
I think it does not, bug 881469 handled this case.

Let's see what QA says.
This issue is reproducible on Flame 3.0. See video for reproduction demonstration:

https://www.youtube.com/watch?v=ZTJmQv-Nuy0

Tested on:
Device: Flame 3.0 Master (full flashed 319MB KK)
BuildID: 20150421010201
Gaia: a8e4f95dce9db727dda5d408b038f97fb4296557
Gecko: 7b823253d9f2
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Whiteboard: [sms-papercuts]
Priority: -- → P3
From my own test we can still trigger 2 navigation requests in the same time but I couldn't manage to reproduce a broken view like the one we see here.

I think this has been properly fixed by bug 1218374.

Maybe we should really prevent interactions while navigating ? I know other apps (eg Contacts) does it.
Let's close this for now.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1218374
You need to log in before you can comment on or make changes to this bug.