Closed Bug 912223 Opened 9 years ago Closed 9 years ago

[Leo][Youtube] When user attempts to change location application does not wait for user to select ok

Categories

(Tech Evangelism Graveyard :: Preinstalled B2G Apps, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: jcouassi, Unassigned)

References

Details

When user selects country user is brought back to main screen, after device quickly cycles thru settings page, without allowing user to select ok

Repro Steps:
1) Updated Leo to Build ID: 20130828155538 Base Build v10a
2) Select and open on 'Youtube' from homescreen
3) Select any Youtube video
4) Tap on 'Menu' button (Top left)
5) Scroll to and select 'Settings'
6) Select 'Location'
7) Select 'Australia'
8) View what is happens

Actual: User is brought back settings and then to main page very quickly

Expected: User is brought back to settings page

Environmental Variables
Build ID: 20130828155538
Gecko: /rev/
Gaia: bcfbffbbb59406b8a07def8ab264792c8d28f23a
Platform Version: 18.1

Notes: This only happens the first time user does this for each country
This actually seems to be the intended behavior, although it is a bit surprising. The issue is that an onchange handler on a select element fires when the user taps an option, not when the user taps ok. I have asked for clarification on dev-gaia about what the UX should be in this case.

Here is a simple repro which displays the behavior:

<!DOCTYPE html>
<html>
    <head>
        <title>Select box test</title>
        <style>select { font-size: 64px; }</style>
    </head>
    <body>
        <script>
function select_changed() {
    window.location = "http://www.google.com";
}
        </script>
        <select onchange="select_changed()">
            <option>Foo</option>
            <option>Bar</option>
            <option>Baz</option>
        </select>
    </body>
</html>
It looks like "onblur" might be the right event handler to use here instead of "onchange".
(In reply to Donovan Preston from comment #2)
> It looks like "onblur" might be the right event handler to use here instead
> of "onchange".

Why is that the intended behaviour? Not per spec I believe.
(In reply to Mounir Lamouri (:mounir) from comment #3)
> (In reply to Donovan Preston from comment #2)
> > It looks like "onblur" might be the right event handler to use here instead
> > of "onchange".
> 
> Why is that the intended behaviour? Not per spec I believe.

It matches the behavior that iOS has with <select><option> menus. If you have more information about what the right thing to do is, that would be helpful.
YouTube says this works as intended.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.