Intermittent test_punycodeURIs.js,test_handlerService.js | test failed (with xpcshell return code: 3), see following log:

RESOLVED FIXED in Firefox 26

Status

RESOLVED FIXED
5 years ago
2 years ago

People

(Reporter: RyanVM, Assigned: mihneadb)

Tracking

({intermittent-failure})

Trunk
mozilla26
x86
Windows 7
intermittent-failure
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox24 unaffected, firefox25 unaffected, firefox26 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Not sure if this is parxpc-related or not.

https://tbpl.mozilla.org/php/getParsedLog.php?id=27335259&tree=Mozilla-Inbound

Windows 7 32-bit mozilla-inbound opt test xpcshell on 2013-09-03 11:39:06 PDT for push 1eacd8262e0f
slave: t-w732-ix-031

11:54:32     INFO -  Retrying tests that failed when run in parallel.
11:54:32     INFO -  TEST-INFO | C:\slave\test\build\tests\xpcshell\tests\dom\indexedDB\test\unit\test_overlapping_transactions.js | running test ...
11:55:12     INFO -  TEST-PASS | C:\slave\test\build\tests\xpcshell\tests\dom\indexedDB\test\unit\test_overlapping_transactions.js | test passed (time: 40190.000ms)
11:55:12     INFO -  TEST-INFO | C:\slave\test\build\tests\xpcshell\tests\image\test\unit\test_async_notification_animated.js | running test ...
11:55:13     INFO -  TEST-PASS | C:\slave\test\build\tests\xpcshell\tests\image\test\unit\test_async_notification_animated.js | test passed (time: 124.000ms)
11:55:13     INFO -  TEST-INFO | C:\slave\test\build\tests\xpcshell\tests\image\test\unit\test_async_notification.js | running test ...
11:55:13     INFO -  TEST-PASS | C:\slave\test\build\tests\xpcshell\tests\image\test\unit\test_async_notification.js | test passed (time: 123.000ms)
11:55:13     INFO -  TEST-INFO | C:\slave\test\build\tests\xpcshell\tests\services\healthreport\tests\xpcshell\test_healthreporter.js | running test ...
11:55:53     INFO -  TEST-PASS | C:\slave\test\build\tests\xpcshell\tests\services\healthreport\tests\xpcshell\test_healthreporter.js | test passed (time: 40612.000ms)
11:55:53     INFO -  TEST-INFO | C:\slave\test\build\tests\xpcshell\tests\services\metrics\tests\xpcshell\test_metrics_storage.js | running test ...
11:56:27     INFO -  TEST-PASS | C:\slave\test\build\tests\xpcshell\tests\services\metrics\tests\xpcshell\test_metrics_storage.js | test passed (time: 33460.000ms)
11:56:27     INFO -  TEST-INFO | C:\slave\test\build\tests\xpcshell\tests\uriloader\exthandler\tests\unit\test_punycodeURIs.js | running test ...
11:56:27  WARNING -  TEST-UNEXPECTED-FAIL | C:\slave\test\build\tests\xpcshell\tests\uriloader\exthandler\tests\unit\test_punycodeURIs.js | test failed (with xpcshell return code: 3), see following log:
11:56:27     INFO -  >>>>>>>
11:56:27     INFO -  *** HandlerServiceTest: getFile: requesting UMimTyp
11:56:27     INFO -  *** HandlerServiceTest: getFile: requesting CurProcD
11:56:27     INFO -  *** HandlerServiceTest: the following NS_ERROR_FAILURE exception in nsIDirectoryServiceProvider::getFile is expected, as we don't provide the 'CurProcD' file
11:56:27     INFO -  <<<<<<<
11:56:27     INFO -  TEST-INFO | C:\slave\test\build\tests\xpcshell\tests\uriloader\exthandler\tests\unit\test_handlerService.js | running test ...
11:56:27  WARNING -  TEST-UNEXPECTED-FAIL | C:\slave\test\build\tests\xpcshell\tests\uriloader\exthandler\tests\unit\test_handlerService.js | test failed (with xpcshell return code: 3), see following log:
11:56:27     INFO -  >>>>>>>
11:56:27     INFO -  *** HandlerServiceTest: getFile: requesting UMimTyp
11:56:27     INFO -  *** HandlerServiceTest: getFile: requesting CurProcD
11:56:27     INFO -  *** HandlerServiceTest: the following NS_ERROR_FAILURE exception in nsIDirectoryServiceProvider::getFile is expected, as we don't provide the 'CurProcD' file
11:56:27     INFO -  <<<<<<<
11:56:27     INFO -  INFO | c:\users\cltbld\appdata\local\temp\tmplzx17h could not be cleaned up.
11:56:27     INFO -  INFO | c:\users\cltbld\appdata\local\temp\tmptzne6e could not be cleaned up.
11:56:27     INFO -  INFO | c:\users\cltbld\appdata\local\temp\tmpty7mx4 could not be cleaned up.
11:56:27     INFO -  INFO | Result summary:
11:56:27     INFO -  INFO | Passed: 1830
11:56:27  WARNING -  INFO | Failed: 2
11:56:27  WARNING -  One or more unittests failed.
11:56:27     INFO -  INFO | Todo: 3
11:56:27     INFO -  INFO | Retried: 7
11:56:27    ERROR - Return code: 1
(Assignee)

Comment 1

5 years ago
I also opened 911607. Don't know who to CC on this.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 14

5 years ago
Ted, who could we ask to look into this? I checked hg log and the only person I could find who actually wrote code for the test (rather than just sed/disabling) is mbanner, and he un-cc'd himself.

*confused*
Flags: needinfo?(ted)
Comment hidden (Treeherder Robot)
I don't see any other more plausible candidates. Standard8 wrote the punycodeURI test, so if he doesn't have a clue we might be stuck.

I do note that these tests seem to be using CurProcD:
http://mxr.mozilla.org/mozilla-central/source/uriloader/exthandler/tests/unit/head_handlerService.js#88

which maybe could cause problems if they're running in parallel with each other.
Flags: needinfo?(ted) → needinfo?(mbanner)
(In reply to Mihnea Dobrescu-Balaur (:mihneadb) from comment #14)
> Ted, who could we ask to look into this? I checked hg log and the only
> person I could find who actually wrote code for the test (rather than just
> sed/disabling) is mbanner, and he un-cc'd himself.

Unfortunately, you cc'ed me on a bug about print being undefined in a head file I never remembered creating or touching...

(In reply to Ted Mielczarek [:ted.mielczarek] from comment #16)
> I do note that these tests seem to be using CurProcD:
> http://mxr.mozilla.org/mozilla-central/source/uriloader/exthandler/tests/
> unit/head_handlerService.js#88
> 
> which maybe could cause problems if they're running in parallel with each
> other.

I think that's the most likely cause, making this a regression from the parallel xpcshell test switch.
Flags: needinfo?(mbanner)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 19

5 years ago
(In reply to Mark Banner (:standard8) from comment #17)
> (In reply to Mihnea Dobrescu-Balaur (:mihneadb) from comment #14)
> > Ted, who could we ask to look into this? I checked hg log and the only
> > person I could find who actually wrote code for the test (rather than just
> > sed/disabling) is mbanner, and he un-cc'd himself.
> 
> Unfortunately, you cc'ed me on a bug about print being undefined in a head
> file I never remembered creating or touching...
> 

The failure was caused from within this test.

> (In reply to Ted Mielczarek [:ted.mielczarek] from comment #16)
> > I do note that these tests seem to be using CurProcD:
> > http://mxr.mozilla.org/mozilla-central/source/uriloader/exthandler/tests/
> > unit/head_handlerService.js#88
> > 
> > which maybe could cause problems if they're running in parallel with each
> > other.
> 
> I think that's the most likely cause, making this a regression from the
> parallel xpcshell test switch.

If a test fails we try to run it in isolation at the end of the run so I don't think this is the reason. I'll look into the curprocD thing.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 26

5 years ago
Created attachment 800942 [details] [diff] [review]
Run exthandler xpcshell tests sequentially to get rid of intermittent failures.

I don't know what the problem is. We don't see any actual logs of what happens. The
mentioned exception is expected, as per the log message.

The harness reruns the test sequentially if it fails when run in parallel, but
I'm thinking maybe something modifies some file on the disk on the first run and
so the 2nd one will fail anyway.

Let's try running them sequentially and see if the intermittent goes away. There
is no real perf difference (1.7s vs 1.5s on my computer).
Attachment #800942 - Flags: review?(ted)
(Assignee)

Updated

5 years ago
Assignee: nobody → mihneadb
Status: NEW → ASSIGNED
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Attachment #800942 - Flags: review?(ted) → review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
Comment hidden (Treeherder Robot)
(Reporter)

Comment 39

5 years ago
https://hg.mozilla.org/integration/fx-team/rev/bfb6901822f6
Flags: in-testsuite-
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
(Reporter)

Comment 40

5 years ago
https://hg.mozilla.org/mozilla-central/rev/bfb6901822f6
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → mozilla26
(Reporter)

Updated

5 years ago
status-firefox24: --- → unaffected
status-firefox25: --- → unaffected
status-firefox26: --- → fixed
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.