[Keyboard][V1.2] The un-installed keyboard still displays on layout selection menu

VERIFIED FIXED

Status

VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: whsu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [FT:System-Platform], [Sprint:3])

(Reporter)

Description

5 years ago
* Description:
  This problem happens on v1.2 build(M-C).
  If you uninstall a third party keyboard then launch the layout selection menu of keyboard, the name of uninstalled keyboard is still here.


* Reproduction steps:
  1. Install the third party keyboard and enable it
  2. Uninstall third party keyboard
  3. Launch the browser app
  4. Tap URL field
  5. Long press the "Global" key after keyboard pop up

* Expected result:
  The layout selection menu doesn't have the uninstalled keyboard name

* Actual result:
  The name of uninstalled keyboard is still here.

* Reproduction build:(Mozilla-central-unagi-eng/2013-09-02-04-02-02)
  + Mercurial-Information
    - Gecko revision="0457c197a382a219b1050fd2ccfddfdbbdad7a92"
  + Git-information
    - Gaia revision="1179318fb5aa"
  + Gecko version: 26.0a1
(Reporter)

Comment 1

5 years ago
Sorry! Attaching the test URL of third party keyboard.
- http://mpizza.github.io/ime/install.html

Please use browser to open it and tap "Install 3rdIME for Firefox OS" to install 3rd keyboard.
Hi William,

It works fine on Mozilla-central-inari/2013-09-12-04-02-01.
It might be fixed by the latest installation process.

My gaia revision is 4ad9fb3beafb075367017de4fdc4d85b1b52f8e0.
Flags: needinfo?(whsu)
(Reporter)

Comment 3

5 years ago
Hi, Luke,

Thanks for your reminder.
I will verify the patch on the latest PVT build.
(Reporter)

Comment 4

5 years ago
Thank you.
Verified it. I cannot reproduce it now.

* Test Build:
 - Gaia:     9cb0bf07dd6b8c23ee4c4db3d866464077f81e45
 - Gecko:    afc0d277a978e95a9c74d1daa41af0bd15c4d6e6
 - BuildID   20130916060051
 - Version   26.0a1
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(whsu)
Resolution: --- → FIXED
(Reporter)

Comment 5

5 years ago
--------- Change the status to "VERIFIED" ---------
Status: RESOLVED → VERIFIED
(Reporter)

Updated

5 years ago
Depends on: 891669
You need to log in before you can comment on or make changes to this bug.