umask ignored for downloaded files

RESOLVED DUPLICATE of bug 919076

Status

()

RESOLVED DUPLICATE of bug 919076
5 years ago
5 years ago

People

(Reporter: devel, Unassigned)

Tracking

({regression})

26 Branch
x86_64
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20130903030201

Steps to reproduce:

1. Set umask to 0022
2. download any file (e.g. a pdf file) to Downloads directory
3. list permissions


Actual results:

$ ls -al pdf-test.pdf
-rw------- 1 freundt users 20597 2013-09-04T09:57:19 pdf-test.pdf



Expected results:

$ ls -al pdf-test.pdf
-rw-r--r-- 1 freundt users 20597 2013-09-04T09:57:19 pdf-test.pdf

in words: the permissions should have been 0644
Component: Untriaged → Downloads Panel

Comment 1

5 years ago
Bug presents since Firefox/24.0
(arch linux)

Comment 2

5 years ago
Confirmed and a very bad issue for multi-user environments.  Users are downloading files that cannot be opened by other people, it's not honoring the umask of the shell.

Comment 3

5 years ago
I also have this issue and its an annoyance.

Firefox 24, x64, Slackware Linux 14.
tracking-firefox-esr24: --- → ?
We really need to track down what regressed this.
Keywords: regressionwindow-wanted

Comment 5

5 years ago
Is it bug 919076 ?

Comment 6

5 years ago
In local build,
Last Good: 43c0123f158b
First Bad: b6cce1e41253

Regressed by:	b6cce1e41253	Monica Chew — Move execution from nsExternalAppHandler to nsDownload (b=858234, r=paolo)
Blocks: 858234
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regressionwindow-wanted → regression
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 919076
tracking-firefox-esr24: ? → ---
You need to log in before you can comment on or make changes to this bug.