Input type=number loses focus when "Search for text when I start typing" is enabled.

RESOLVED DUPLICATE of bug 791653

Status

()

Core
DOM: Core & HTML
RESOLVED DUPLICATE of bug 791653
4 years ago
4 years ago

People

(Reporter: Mark Straver, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130829135643

Steps to reproduce:

1. Enable type=number input html5 form element with dom.experimental_forms
2. Enable "Search for text when I start typing" in Options -> Advanced -> General
3. Go to http://www.w3schools.com/html/tryit.asp?filename=tryhtml5_input_type_number
4. Try typing in the input box


Actual results:

Focus is shifted to the search box (input type=number is not considered an input field). It's impossible to type anything in the input field.


Expected results:

Focus should remain on the input field, like it does when type=number is disabled.
(Reporter)

Updated

4 years ago

Updated

4 years ago
Blocks: 344616
Status: UNCONFIRMED → NEW
Component: Untriaged → DOM: Core & HTML
Ever confirmed: true
Product: Firefox → Core
Version: 24 Branch → Trunk

Comment 1

4 years ago
I think it's a duplicate of bug 791653. But this one gives a better explanation of what happens: "Focus is shifted to the search box (input type=number is not considered an input field)".
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 791653
You need to log in before you can comment on or make changes to this bug.