Crash on fishie-fast (ABORT: not reached: file ../../../../gfx/layers/ipc/ImageBridgeChild.cpp, line 452)

RESOLVED DUPLICATE of bug 912173

Status

()

Core
Graphics
--
major
RESOLVED DUPLICATE of bug 912173
4 years ago
2 years ago

People

(Reporter: Aaron Kaluszka, Unassigned)

Tracking

({crash, regression})

Trunk
x86_64
Mac OS X
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

4 years ago
I am getting a crash on the fishie-fast benchmark. The page initially loads, but all of the fish show up as black rectangles. Then, before they have a chance to animate, the whole browser goes down without a crash report.

User Agent 	Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:26.0) Gecko/20100101 Firefox/26.0

Graphics
Device ID	0x fd5
GPU Accelerated Windows	2/2 OpenGL (OMTC)
Vendor ID	0x10de
WebGL Renderer	NVIDIA Corporation -- NVIDIA GeForce GT 650M OpenGL Engine
windowLayerManagerRemote	true
AzureCanvasBackend	quartz
AzureContentBackend	quartz
AzureFallbackCanvasBackend	none
AzureSkiaAccelerated	0
Confirmed:
https://crash-stats.mozilla.com/report/index/51deb8a2-955a-406d-9545-17cd42130904
Flags: needinfo?(matt.woodrow)
Keywords: regression, regressionwindow-wanted
Only happens with OMTC
Blocks: 756601

Updated

4 years ago
Crash Signature: [@ mozalloc_abort(char const*) | NS_DebugBreak | HexEncode(void const*, unsigned long)::kHexChars ]
Summary: Crash on fishie-fast → Crash on fishie-fast (ABORT: not reached: file ../../../../gfx/layers/ipc/ImageBridgeChild.cpp, line 452)
I can only reproduce bug 912173 on this page, nothing that looks like this stack.
Flags: needinfo?(matt.woodrow)
Maybe this was related to Nical' ImageBridge changes.
(Reporter)

Comment 5

4 years ago
Well, at least I got a crash report this time: https://crash-stats.mozilla.com/report/index/90f306e4-4873-4900-9f00-9f6c22130909
I *think* that is the same as bug 912173, although with an entirely different stack. It appears that the GLContext is invalid when we're trying to make it current, which fits with the other bug.

It should be fixed in the next nightly.
(Reporter)

Comment 7

4 years ago
Looks like it. Fixed in today's nightly.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 912173
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.