[Messages] hiding and showing the app repeatedly make it blank

RESOLVED DUPLICATE of bug 920890

Status

Firefox OS
General
RESOLVED DUPLICATE of bug 920890
5 years ago
5 years ago

People

(Reporter: julienw, Assigned: jrmuizel)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:koi+)

Details

(Reporter)

Description

5 years ago
STR:
* launch the Messages app
* press home, and immediately tap the Messages app icon again
* repeat until you get a blank screen (this should happen at the first or second try)
* you want wait as much as you can, this never recover unless you do one of the following workarounds:
  + press home again and tap the Messages app icon again
  + lock the screen and unlock

Asking koi on this. This is a regression because I think this does not happen in 1.0.1, but it _does_ happen with 1.1, therefore I'm very tempted to ask for leo.

This is not recent, I see this for a long time, and was just too lazy to file a bug.
(Reporter)

Comment 1

5 years ago
Gabriele, I would love to try a profile with you. I tried but I think I don't do it correctly as the results look weird.
Flags: needinfo?(gsvelto)
I'm doing an up-to-date v1-train build for my Leo, we're going to test it there and see if we can reproduce the issue. I'm not sure if profiling is the best way of figuring out what's going on, we might need to break in with GDB to figure out what's happening.
(Reporter)

Comment 3

5 years ago
I tried with another phone (not unagi) and I didn't see this bug. Maybe this is fixed in a more current build, I'll flash my phone with more current code.
Flags: needinfo?(felash)
I've tested with v1-train on a Unagi and with the master branch on my Hamachi and I can reproduce on the Hamachi. Unfortunately my Hamachi build seems to have other problems too so I want to double-check as soon as I have some extra time.
Flags: needinfo?(gsvelto)
(Reporter)

Comment 5

5 years ago
Reproduced on the latest nightly for keon too. (nightly-images-keon-master-2013-09-23.Gecko-f156bef.Gaia-3786676.zip)
Flags: needinfo?(felash)
(Reporter)

Comment 6

5 years ago
Some more information:
* I see this on other apps too, eg Dialer
* I see the app is reacting when I'm touching the screen (eg: in Messages, the keyboard is showing up; in Dialer, I see JS errors about a sound-producing file)

so moving components
Component: Gaia::SMS → General
Could be related to bug 918671.
Assignee: nobody → jmuizelaar
blocking-b2g: koi? → koi+
And it's likely a duplicate of bug 920890, which has some traction on the fix.
+1. It happens on lots of apps (like Alarm App).
(Reporter)

Comment 10

5 years ago
Duping against bug 920890 which is worked upon.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 920890
You need to log in before you can comment on or make changes to this bug.