Closed Bug 913043 Opened 7 years ago Closed 7 years ago

[adbe 3627468] Flash 11.9 crash in F1987069282

Categories

(External Software Affecting Firefox :: Flash (Adobe), defect, critical)

x86
Windows NT
defect
Not set
critical

Tracking

(firefox23 affected, firefox24 affected, firefox25 affected)

RESOLVED FIXED
Tracking Status
firefox23 --- affected
firefox24 --- affected
firefox25 --- affected

People

(Reporter: kairo, Unassigned)

Details

(Keywords: crash, topcrash, Whiteboard: [Flash 11.9][fixed in Flash 11.9.900.110])

Crash Data

This bug was filed from the Socorro interface and is 
report bp-efcd23ad-7791-48b1-af83-d880c2130905.
=============================================================

This is a new crash in the Flash 11.9.900.85 version that just appeared yesterday. See https://crash-stats.mozilla.com/report/list?signature=F1987069282_____________________________________________________________ for more crash reports and details.
Thanks.  This is Adobe 3627468
Summary: Flash 11.9.900.85 crash in F1987069282_____________________________________________________________ → [adbe 3627468] Flash 11.9.900.85 crash in F1987069282
Highly explosive on 24b8 accounting for 50% of all crashes so far.
50% of all crashes in what? Flash 11.9? All plugin crashes? Or all Firefox beta crashes? Flash 11.9 is the Flash beta, and is currently installed by less than 4% of the beta population.
Flags: needinfo?(twalker)
It's ~60% of all reports from this new Flash beta: https://crash-analysis.mozilla.com/rkaiser/2013-09-05/2013-09-05.firefox.flash.11-9-900-85.html

Completely on Adobe's side though, no need to track for releases on our side.
sorry, yes, 50% of this particular crash occur on 24beta8.
Flags: needinfo?(twalker)
STR:

1) Upgrade to Flash 11.9.900.85
2) watch any youtube video
3) switch to watch it in fullscreen
4) press esc to return to normal browser view

crash every time.

Fx doesn't crash, just the flash process.
Tracy, can you clarify the configuration (OS x86|x64 and FF version) you're using to reproduce this? I'm not seeing it on Win7 x64 with 23.0.1.
Jeromie, I was running in a Windows 7 vm with Fx 24.0 beta 8.
(In reply to Tracy Walker [:tracy] from comment #9)
>> (In reply to Jeromie Clark from comment #8)
>> Tracy, can you clarify the configuration (OS x86|x64 and FF version) you're
>> using to reproduce this? I'm not seeing it on Win7 x64 with 23.0.1.
>
> Jeromie, I was running in a Windows 7 vm with Fx 24.0 beta 8.

Jeromie, is this information sufficient? Do you have any update on your investigation?
I got the same crash on Windows 8.1 64-bit and Flash 11.9.900.93:
https://crash-stats.mozilla.com/report/index/cc566905-80c9-462c-b6cf-bc1572130911

The steps that I used when the crash occurred are very similar with the ones from Comment 3 (entered and exited full screen on a YouTube video).

For me, the issue is easily reproducible on a PC running Windows 8.1 with an ATI Radeon 3000 video card, but it reproduces more rarely with other cards (ATI Radeon HD 5450).
Since the steps to reproduce were already provided in Comment 7, I'm removing the "qawanted" and "steps-wanted" keywords. Please add the "qawanted" keyword back if anything else is needed from the QA side.
Thanks Simona, can you please quickly check Nightly and set the status-firefox26 flag to affected if it's affected too?
Anthony, this is a Flash crash, it affects any Firefox version on which you install this Flash beta, it's in their plugin code. There's no need for us to pour any QA work into it at this point, really. If Adobe needs our help, Jeromie will ask for it, but unless that happens, there is no need for us to use time on it or track it.
This is still happening in Flash 11.9.900.93.
Summary: [adbe 3627468] Flash 11.9.900.85 crash in F1987069282 → [adbe 3627468] Flash 11.9 crash in F1987069282
This has spiked pretty severely in Firefox 25.0b1 (perhaps expectedly). It is currently the #5 top crash in Firefox 25 with a 3-day explosiveness rating of 3.0.

Deltas (crashes per 1M ADU):
> Firefox 25.0a2: 53 to 187
> Firefox 25.0b1: 432 to 592
Keywords: topcrash
We'll have a blind fix for this in tomorrow's Flash Player beta.
(In reply to Jeromie Clark from comment #17)
> We'll have a blind fix for this in tomorrow's Flash Player beta.

Thanks, we'll check for that in the stats for sure.
It looks like this is fixed in Flash 11.9.900.110 (current beta).
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [Flash 11.9] → [Flash 11.9][fixed in Flash 11.9.900.110]
You need to log in before you can comment on or make changes to this bug.