Closed Bug 913124 Opened 6 years ago Closed 6 years ago

js/src/jsreflect.cpp:1483:7: warning: 'ASTSerializer' has a field 'ASTSerializer::builder' whose type uses the anonymous namespace [enabled by default]

Categories

(Core :: JavaScript Engine, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla26

People

(Reporter: dholbert, Assigned: dholbert)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

New GCC 4.8 build warning:
{
js/src/jsreflect.cpp:1483:7: warning: 'ASTSerializer' has a field 'ASTSerializer::builder' whose type uses the anonymous namespace [enabled by default]
}

This was caused by bug 910829's patch, which put NodeBuilder into an anonymous namespace.
https://hg.mozilla.org/integration/mozilla-inbound/rev/c0104d0c88a1#l13.1
(Simplest solution would probably be to put ASTSerializer itself into the anonymous namespace, if that works.)
This works locally.
Assignee: general → dholbert
Status: NEW → ASSIGNED
Attachment #800304 - Flags: review?(jwalden+bmo)
Attachment #800304 - Flags: review?(jwalden+bmo) → review+
https://hg.mozilla.org/mozilla-central/rev/55cdc3eef815
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
You need to log in before you can comment on or make changes to this bug.