Closed Bug 913590 Opened 11 years ago Closed 11 years ago

lepoint.fr returns desktop site for firefox OS 1.1

Categories

(Web Compatibility :: Site Reports, defect)

Other
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: bkelly, Assigned: karlcow)

References

()

Details

(Whiteboard: [mobile-compat-form] [serversniff] [clientsniff] [country-fr] [sitewait])

Site: http://www.lepoint.fr
lepoint.fr returns desktop site for firefox OS

:: Steps To Reproduce

1. Visit www.lepoint.fr on firefox OS

:: Expected Result

mobile.lepoint.fr site should be returned

:: Actual Result

the desktop site is returned instead

:: Additional Information

Software Version: FirefoxOS 1.1
Reporter's User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0
Ben,

Bug 907064 is NOT a duplicate of this bug. These are two different issues. Could you either reopen or close the 907064?
Flags: needinfo?(bkelly)
(In reply to Karl Dubost :karlcow from comment #2)
> Bug 907064 is NOT a duplicate of this bug. These are two different issues.
> Could you either reopen or close the 907064?

Done.  Whats the correct way to handle bugs that are filed as performance issue, but it appears its due to a desktop site is being returned for a mobile device?  Thanks.
Flags: needinfo?(bkelly)
Offtopic for this bug. I'm going to comment on Bug 907064
OK this one is interesting.
Both Firefox for Android and Firefox OS User Agent strings are redirected to the mobile site.

But then on the ZTE device, the site shown is the desktop site with http://www.lepoint.fr/
On the Firefox for Android device, the site shown is the mobile site http://mobile.lepoint.fr/

# Firefox for Android

GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: www.lepoint.fr
User-Agent: Mozilla/5.0 (Android; Mobile; rv:18.0) Gecko/18.0 Firefox/18.0

HTTP/1.1 301 Moved Permanently
Content-Encoding: gzip
Content-Length: 34526
Content-Type: text/html
Date: Wed, 11 Sep 2013 13:12:16 GMT
Location: http://mobile.lepoint.fr/
Server: Apache/2.2.25 (Unix) PHP/5.2.17
Vary: User-Agent,Accept-Encoding
X-Powered-By: PHP/5.2.17


# Firefox OS

GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: www.lepoint.fr
User-Agent: Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0

HTTP/1.1 301 Moved Permanently
Content-Encoding: gzip
Content-Length: 34525
Content-Type: text/html
Date: Wed, 11 Sep 2013 13:12:21 GMT
Location: http://mobile.lepoint.fr/
Server: Apache/2.2.25 (Unix) PHP/5.2.17
Vary: User-Agent,Accept-Encoding
X-Powered-By: PHP/5.2.17


On the desktop site I can find:

<link rel="alternate" media="only screen and (max-width: 640px)" href="http://mobile.lepoint.fr" />
<link rel="alternate" media="handheld" href="http://mobile.lepoint.fr" />

If I type directly http://mobile.lepoint.fr/ on the ZTE, it is working. At least it is not going back to the desktop site.


There's one mobile detection script.
http://preroll.a4.tl/lepoint/js/detecte.js

function DetecteUA() {
var strUAgent = navigator.userAgent;
strUAgent = strUAgent.toLowerCase();
if (strUAgent.indexOf("iphone") >= 0) {
return "iphone"
} else if (strUAgent.indexOf("android") >= 0 && strUAgent.indexOf("mobile") >= 0) {
return "android"
} else if (strUAgent.indexOf("blackberry") >= 0) {
return "blackberry"
} else if (strUAgent.indexOf("ipad") >= 0) {
return "ipad"
} else {
return "autre"
}
}

So I wonder if the server sends to the mobile site but then the JavaScript sends the user back to the desktop site through storage parameters.


Mike, Hallvors, If you get a genius idea idea on how they do that. :)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [mobile-compat-form] → [mobile-compat-form] [serversniff] [clientsniff] [country-fr]
Whiteboard: [mobile-compat-form] [serversniff] [clientsniff] [country-fr] → [mobile-compat-form] [serversniff] [clientsniff] [country-fr] [contactready]
Sigh. This site actually distinguishes FirefoxOS 1.0 (detected as mobile) and 1.1 (detected as desktop). They really rely on the "18.0" version being in the UA string.
Summary: lepoint.fr returns desktop site for firefox OS → lepoint.fr returns desktop site for firefox OS 1.1
I will contact them.
So indeed it looks like the User Agent string is hardcoded. Strange.


# Firefox OS 18.0 gets the mobile

GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: www.lepoint.fr
User-Agent: Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0

HTTP/1.1 301 Moved Permanently
Content-Encoding: gzip
Content-Length: 40987
Content-Type: text/html
Date: Wed, 27 Nov 2013 16:47:53 GMT
Location: http://mobile.lepoint.fr/
Server: Apache/2.2.25 (Unix) PHP/5.2.17
Vary: User-Agent,Accept-Encoding
X-Powered-By: PHP/5.2.17



# Firefox OS 18.1 gets the desktop

GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: www.lepoint.fr
User-Agent: Mozilla/5.0 (Mobile; rv:18.1) Gecko/18.1 Firefox/18.1

HTTP/1.1 200 OK
Content-Encoding: gzip
Content-Length: 40642
Content-Type: text/html
Date: Wed, 27 Nov 2013 16:48:58 GMT
Server: Apache/2.2.25 (Unix) PHP/5.2.17
Vary: User-Agent,Accept-Encoding
X-Powered-By: PHP/5.2.17
Assignee: nobody → kdubost
Status: NEW → ASSIGNED
Whiteboard: [mobile-compat-form] [serversniff] [clientsniff] [country-fr] [contactready] → [mobile-compat-form] [serversniff] [clientsniff] [country-fr] [sitewait]
Contacted through their website form.
They replied and are working on it.
This is fixed. Thanks to Le Point Team.



GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: www.lepoint.fr
User-Agent: Mozilla/5.0 (Mobile; rv:25.0) Gecko/25.0 Firefox/25.0

HTTP/1.1 301 Moved Permanently
Content-Encoding: gzip
Content-Length: 41199
Content-Type: text/html
Date: Fri, 06 Dec 2013 18:47:57 GMT
Location: http://mobile.lepoint.fr/
Server: Apache/2.2.25 (Unix) PHP/5.2.17
Vary: User-Agent,Accept-Encoding
X-Powered-By: PHP/5.2.17
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
verified by automated testing
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Web Compatibility
Component: Mobile → Site Reports
You need to log in before you can comment on or make changes to this bug.