Attempting to print page results in a crash

VERIFIED DUPLICATE of bug 90060

Status

()

Core
Printing: Output
VERIFIED DUPLICATE of bug 90060
17 years ago
17 years ago

People

(Reporter: Chris Petersen, Assigned: dcone (gone))

Tracking

Trunk
x86
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Build: 2001071805
Platform: Windows
Expected results: Application shouldn't crash after printing
What I Got: Application crashes

Steps to reproduce:

1) Go to url
2) Print page
3) Crash immediately occurs

Talkback stack trace:

nsContainerFrame::PaintChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 187]
nsBlockFrame::PaintFloaters
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 5141]
nsBlockFrame::Paint
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 5072]
nsContainerFrame::PaintChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 229]
nsBlockFrame::PaintChildren
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 5196]
nsBlockFrame::Paint
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 5074]
nsContainerFrame::PaintChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 229]
nsContainerFrame::PaintChildren
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 173]
nsContainerFrame::Paint
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 155]
nsPageFrame::Paint
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPageFrame.cpp, line 384]
PresShell::Paint
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5297]
nsView::Paint [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 275]
nsViewManager::RenderDisplayListElement
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 1439]
nsViewManager::RenderViews
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 1364]
nsViewManager::Display [d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp,
line 3011]
nsSimplePageSequenceFrame::PrintNextPage
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsSimplePageSequence.cpp, line
756]
DocumentViewerImpl::PrintPage
[d:\builds\seamonkey\mozilla\content\base\src\nsDocumentViewer.cpp, line 2224]
nsPagePrintTimer::Notify
[d:\builds\seamonkey\mozilla\content\base\src\nsDocumentViewer.cpp, line 615]
nsTimer::Fire [d:\builds\seamonkey\mozilla\widget\timer\src\windows\nsTimer.cpp,
line 200]
nsTimerManager::FireNextReadyTimer
[d:\builds\seamonkey\mozilla\widget\timer\src\windows\nsTimerManager.cpp, line 117]
nsAppShell::Run [d:\builds\seamonkey\mozilla\widget\src\windows\nsAppShell.cpp,
line 118]
nsAppShellService::Run
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsAppShellService.cpp, line 426]
NETSCP6.EXE + 0x16f0 (0x004016f0)
NETSCP6.EXE + 0x11b8 (0x004011b8)
NETSCP6.EXE + 0x3243 (0x00403243)
KERNEL32.DLL + 0x1b9e4 (0xbff7b9e4)
KERNEL32.DLL + 0x1b896 (0xbff7b896)
KERNEL32.DLL + 0x1a24f (0xbff7a24f)
(Reporter)

Comment 1

17 years ago
I can't reproduce crash with the Mac branch build (2001071703) running under Mac
0S 9.1.
(Assignee)

Comment 2

17 years ago
I think this page runs a script..I noticed the page changed when I tried to 
print.. and then a crash.. I think the document viewer gets deleted out from 
under the print job.. this is a duplicate of bug #90060.  There is another bug 
also that does this.. but has different symptoms.  I am sure this is because the 
documentviewer is deleted before the print job is complete.

*** This bug has been marked as a duplicate of 90060 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
okay we will re-verify this one after 90060 is fixed...thanks Don...
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

17 years ago
Works fine in the latest Windows build (2001-08-09-07). Tested under Windows Me.
You need to log in before you can comment on or make changes to this bug.