Closed Bug 913738 Opened 6 years ago Closed 6 years ago

[B2G] [Buri] [1.2] [Dialer] Caller is unable to hang up after a second call is made while connected to the first call

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 905941

People

(Reporter: ckreinbring, Unassigned)

Details

Attachments

(2 files)

Description:
After making a call while already connected to a call, the caller will be stuck on the call screen of the first caller when both called devices hang up.  A possible suspect is "E/AudioPolicyManager(144): setPhoneState() state 0"

Repro Steps:
1) Update Buri to Build ID: 20130906040204
2) Make a call to another device and have the device answer it.
3) While in the call, tap the New Call button (call symbol with a + next to it).
4) Call another device and have that device answer.
5) Attempt to hang up on either call.

Actual:
The caller is unable to hang up on either call.  The hang up button does not respond, and attempts to close the dialer by long-tapping the Home button fail.

Expected:
The caller can hang up on both calls.

Environmental Variables
Occurs on Buri 1.2 mozilla RIL
Build ID: 20130906040204
Gecko: http://hg.mozilla.org/mozilla-central/rev/ab5f29823236
Gaia: 94e5f269874b02ac0ea796b64ab995fce9efa4b3
Platform Version: 26.0a1
RIL Version: 01.01.00.019.206 

Notes:
Repro frequency: 100%
See attached logcat logs
The only way to become unstuck is to restart the device
No longer blocks: b2g-central-dogfood
blocking-b2g: --- → koi?
QA Contact: sparsons
This issue started to occur on the 9/06 build. It seems that this "New Call" or Conference Call feature was recently added because it does not appear on 9/05 1.2 build or earlier. 

Environmental Variables
Occurs on Buri 1.2 mozilla RIL
Build ID: 20130906040204
Gecko: http://hg.mozilla.org/mozilla-central/rev/ab5f29823236
Gaia: 94e5f269874b02ac0ea796b64ab995fce9efa4b3
Platform Version: 26.0a1
RIL Version: 01.01.00.019.206
Looping some Gaia folks.
It doesn't happen on a unagi with the same gecko, so we don't think it's gaia related.
Attached file logburi
It looks like a device-dependent problem. There are ril parcel errors there while I don't see them on unagi.
this seems to be on commercial ril. ni? Anshul/mvines
Flags: needinfo?(mvines)
Flags: needinfo?(anshulj)
There's no 1.2 QA testing happening with commercial RIL at the moment.  But I hope we can fix that soon!  It's certainly available to Moz.
Flags: needinfo?(mvines)
Flags: needinfo?(anshulj)
(In reply to Joe Cheng [:jcheng] from comment #5)
> this seems to be on commercial ril. ni? Anshul/mvines

No it's not - this bug was filed involving the Mozilla RIL build on Buri.
The root cause is the same as bug 905941. Marked as duplicate.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 905941
Not regression. This issue is about Buri device having its own ril parcels.
Keywords: regression
blocking-b2g: koi? → ---
You need to log in before you can comment on or make changes to this bug.