contextmenu events bubbled up to document as clicks

RESOLVED DUPLICATE of bug 569071

Status

()

Core
DOM: Events
RESOLVED DUPLICATE of bug 569071
4 years ago
4 years ago

People

(Reporter: simonzack, Unassigned)

Tracking

23 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 801228 [details]
stopPropogation.html

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130814063812

Steps to reproduce:

Left click/right click the link in the attached document.


Actual results:

In the attached html, right clicking the link is detected by the document element as a click + contextmenu event. This happens in both firefox v23.0.1 and nightly 2013-09-07


Expected results:

I've also tested this in chrome, which has the correct behavior of the right click only being detected as a context menu event.

Updated

4 years ago
Attachment #801228 - Attachment mime type: text/plain → text/html

Updated

4 years ago
Component: Untriaged → DOM: Events
Product: Firefox → Core

Comment 1

4 years ago
It happens in old versions like FF8.

Updated

4 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

4 years ago
I think this is dupe of Bug 569071

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 569071
You need to log in before you can comment on or make changes to this bug.