If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Jetpack crashes show up as timeouts on tbpl

RESOLVED DUPLICATE of bug 873204

Status

Release Engineering
General Automation
RESOLVED DUPLICATE of bug 873204
4 years ago
4 years ago

People

(Reporter: mccr8, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
I wrote a buggy patch that crashed JP, but these just showed up as timeouts in TBPL, which is deceptive, and makes the machine sit there for 5 minutes waiting for the timeout:
  https://tbpl.mozilla.org/?tree=Try&rev=f3122d33c773

Run locally, it shows this in the log:

 0:08.41 Hit MOZ_CRASH() at /home/amccreight/icc/memory/mozjemalloc/jemalloc.c:1572
 0:08.41 
 0:08.41 Program ./dist/bin/firefox-bin (pid = 12946) received signal 11.
 0:08.41 Stack:
... (the stack isn't fully symbolicated, but that's probably a separate bug...)
 0:08.41 Sleeping for 300 seconds.
 0:08.41 Type 'gdb ./dist/bin/firefox-bin 12946' to attach your debugger to this thread.
Component: Tinderboxpushlog → General Automation
Product: Webtools → Release Engineering
QA Contact: catlee
Version: Trunk → unspecified

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 873204
You need to log in before you can comment on or make changes to this bug.