Build tier changes broke comm-central

RESOLVED FIXED in Thunderbird 26.0

Status

MailNews Core
Build Config
--
blocker
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: jcranmer, Assigned: jcranmer)

Tracking

Trunk
Thunderbird 26.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
There are at least three separate issues breaking comm-central right now:

1. One of glandium's several changes broke the proper building of LDAP code.
2. The code tries to "make compile" in c-c, which breaks, obviously.

The third is a windows-specific build which looks unrelated to the fixes needed to get Linux and OS X working, so that will get its own bug.
OS: Windows 7 → All
Hardware: x86_64 → All
See Also: → bug 913528

Updated

4 years ago
Severity: normal → blocker

Updated

4 years ago
Duplicate of this bug: 914083
(Assignee)

Comment 2

4 years ago
Created attachment 801574 [details] [diff] [review]
Fix the build

I didn't feel justified landing this with an r=bustage-fix port, since there is a slight modification to get LDAP working properly.
Assignee: nobody → Pidgeot18
Status: NEW → ASSIGNED
Attachment #801574 - Flags: review?(mbanner)

Comment 3

4 years ago
(In reply to Joshua Cranmer [:jcranmer] from comment #2)
> Created attachment 801574 [details] [diff] [review]
> Fix the build

The fix works for me. But. *g* Now there is again a previous one

processing /home/hafi/moz-work/src/mozilla/extensions/irc/sm/jar.mn
Packaging chatzilla-0.9.90.1.xpi...
cd ../../../dist/xpi-stage/chatzilla && /usr/bin/zip -qr ../chatzilla-0.9.90.1.xpi *
rm -f -r "../../../dist/bin/extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}"
/home/hafi/moz-work/src/obj-x86_64-unknown-linux-gnu/mozilla/config/nsinstall -D "../../../dist/bin/extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}"
(cd ../../../dist/xpi-stage/chatzilla/. && tar -chf - .) | (cd ../../../dist/bin/extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}/. && tar -xf -)
make[7]: Leaving directory `/home/hafi/moz-work/src/obj-x86_64-unknown-linux-gnu/mozilla/extensions/irc/sm'
make[6]: Leaving directory `/home/hafi/moz-work/src/obj-x86_64-unknown-linux-gnu/mozilla/extensions/irc'
make[5]: Leaving directory `/home/hafi/moz-work/src/obj-x86_64-unknown-linux-gnu/mozilla/extensions'
make[4]: *** [libs] Error 2
Comment on attachment 801574 [details] [diff] [review]
Fix the build

Review of attachment 801574 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. r=Standard8
Attachment #801574 - Flags: review?(mbanner) → review+
(Assignee)

Comment 5

4 years ago
https://hg.mozilla.org/comm-central/rev/f4c921623a74
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 26.0
(In reply to Hartmut Figge from comment #3)
> (In reply to Joshua Cranmer [:jcranmer] from comment #2)
> > Created attachment 801574 [details] [diff] [review]
> > Fix the build
> 
> The fix works for me. But. *g* Now there is again a previous one
> 
> processing /home/hafi/moz-work/src/mozilla/extensions/irc/sm/jar.mn
> Packaging chatzilla-0.9.90.1.xpi...
[...]

Can you file a new bug for this? I think this needs to be fixed to get SeaMonkey trunk compiling again.

Comment 7

4 years ago
I have too new bug:

Packaging venkman-0.9.89.xpi...
c:\Users\Vlada\comm-central\mozilla\config\rules.mk:1521:0$ cd ../../dist/xpi-stage/venkman && zip -qr ../venkman-0.9.89.xpi *

zip error: Nothing to do! (try: zip -qr ../venkman-0.9.89.xpi . -i *)
c:\Users\Vlada\comm-central\mozilla\config\rules.mk:1521:0: command 'cd ../../dist/xpi-stage/venkman && zip -qr ../venkman-0.9.89.xpi *' failed, return code 12
evaluation from c:\Users\Vlada\comm-central\mozilla\config\recurse.mk:44:44:7:0: command 'c:/mozilla-build/python/python.exe c:/Users/Vlada/comm-central/mozilla/build/pymake/pymake/../make.py -C venkman libs' failed, return code 2
I filed bug 914560 on the Venkman issue.
SeaMonkey builds are now being produced again for W32, L32 and L64. Not for the Mac but the error has changed: it seems to have something to do with packaging the omnijar.

This hourly that I'm using is the latest L64 build as of this writing:
Mozilla/5.0 (X11; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0 SeaMonkey/2.23a1 ID:20130912192824 c-c:303c7574e706 m-c:b9029b1de410
No nightlies yet.
As have been already requested, please file separate bugs for different errors rather than commenting on closed bugs - in this case its likely to be different especially as Thunderbird trunk is now building (and it was a separate bug that fixed the TB builds).
Indeed, Bug 914560 takes care of SeaMonkey issues (didnt I mention this before :).
You need to log in before you can comment on or make changes to this bug.