[stage] Internal server error(500) on https://crash-stats.allizom.org/

VERIFIED FIXED in 59

Status

Socorro
Webapp
--
blocker
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: AlinT, Unassigned)

Tracking

unspecified
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fromAutomation], URL)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 801409 [details]
500_socorro_stage.png

Accessing https://crash-stats.allizom.org/ returns 500 Internal Server Error
(Reporter)

Updated

5 years ago
Whiteboard: [fromAutomation]
I wasn't able to consistently reproduce a 500 error on stage but they do indeed exist and are playing havoc with our automation. Can we please make stage stable again. Noming to blocker.

[09:03:17.583] GET https://crash-stats.allizom.org/topcrasher/products/Firefox/versions/26.0a1?days=7 [HTTP/1.1 500 INTERNAL SERVER ERROR 122304ms]

Not sure which error is most helpful but here are a few from errormill that occurred during the timeframe I was reproducing AlinT's experiences.

https://errormill.mozilla.org/webtools/socorro-stage/group/97549/
https://errormill.mozilla.org/webtools/socorro-stage/group/99799/
https://errormill.mozilla.org/webtools/socorro-stage/group/97559/
Severity: normal → blocker

Updated

5 years ago
Target Milestone: --- → 59
Issue was caused by failed Postgres database stage refresh.

I applied passwords this morning, reset crontabbers config and stage started working again.
Depends on: 914155

Comment 3

5 years ago
so this this resolved now?
(In reply to Chris Lonnen :lonnen from comment #3)
> so this this resolved now?

Stage appears to be in a healthier state; are we still waiting for the bug 914155 to be resolved?

Updated

5 years ago
Flags: needinfo?(sdeckelmann)

Comment 5

5 years ago
Working now.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
QA verified - we are back in business
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

5 years ago
Created attachment 812581 [details]
Screenshot of the issue

This is reproducible again.
I've attached a screenshot of the issue
(Reporter)

Updated

5 years ago
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Bumping to resolved fixed - stage is up again and we were able to get a passing build - http://qa-selenium.mv.mozilla.com:8080/view/Socorro/job/socorro.stage/172/

We are tracking a different behavior where we're seeing spurious 500's on the reports as well as a potential perf regression on queries (unconfirmed & still investigating). Tracker bug is bug 922662.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Flags: needinfo?(sdeckelmann)
Resolution: --- → FIXED

Updated

4 years ago
Flags: needinfo?(alin.trif)
(Reporter)

Comment 9

4 years ago
It seems this is fixed.
I cannot longer reproduce 500s on the stage site
Bumping to VF
Status: RESOLVED → VERIFIED
Flags: needinfo?(alin.trif)
You need to log in before you can comment on or make changes to this bug.