Main window announced to VoiceOver as "unknown"

RESOLVED FIXED in mozilla26

Status

()

Core
Disability Access APIs
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: MarcoZ, Assigned: MarcoZ)

Tracking

(Blocks: 1 bug, {regression})

Trunk
mozilla26
x86_64
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
The main window for Firefox is no longer being announced to VoiceOver as a window, but as an "unknown". Something broke the AXROLE string for the main window.

STR: 1. With VoiceOver on, start Nightly.
2. Explore the top-most elements. You have a close button, a minimize and a zoom button, and then you have an "unknown" with the current window title spoken.
You can interact with it and use all child elements, but the window itself is no longer a real window in the VoiceOver/Universal Access sense. Accessibility Inspector will probably also show a failure here.
(Assignee)

Comment 1

4 years ago
Created attachment 801566 [details] [diff] [review]
Main window announced to VoiceOver as unknown,
Attachment #801566 - Flags: review?(surkov.alexander)
(Assignee)

Comment 2

4 years ago
Note that the actually correct fix for this bug would be not to expose the ChromeWindow accessible at all, and to expose its direct children as top level items for VoiceOver in the Firefox window instead. This is how all other OS X apps appear. However, since I don't know how to accomplish that, I remapped the ChromeWindow to be exposed as a group rather than an unknown. Note that window didn't work, that ate all the children except the HTML content.

Comment 3

4 years ago
Comment on attachment 801566 [details] [diff] [review]
Main window announced to VoiceOver as unknown,

Review of attachment 801566 [details] [diff] [review]:
-----------------------------------------------------------------

it's reasonable, r=me
Attachment #801566 - Flags: review?(surkov.alexander) → review+

Updated

4 years ago
Assignee: nobody → marco.zehe
(Assignee)

Comment 4

4 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/07ff0d3d9c40
https://hg.mozilla.org/mozilla-central/rev/07ff0d3d9c40
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
You need to log in before you can comment on or make changes to this bug.