Restarting browser after JVM installation asks you to restart browser again..and again

VERIFIED DUPLICATE of bug 84896

Status

Core Graveyard
Java: OJI
VERIFIED DUPLICATE of bug 84896
17 years ago
7 years ago

People

(Reporter: Rodney Velasco, Assigned: edburns)

Tracking

Trunk
Other
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Found this while investigating bug 89488 'the JVM catatonic' bug.  After
installing the JVM from http://home.netscape.com/plugins/jvm.html on linux, File
-> Quitting the browser and restarting the netscape binary gives this erroneus
message...

"The program must close to allow a previous installation attempt to complete.
Please restart"

Yet, I File -> Quit the browser and closed all instances of run-mozilla.sh and
mozilla-bin.  Doing a ps -u I found that xpicleanup is still running even though
the browser process is dead.  This is more of an annoyance since you have to
restart the netscape/mozilla binary twice to get out of that message.

Steps to reproduce:
1. Install latest build using reccommended option (don't install Java is the key
point)
2. Go to http://home.netscape.com/plugins/jvm.html and download the Java Plugin
for linux
3. File -> Quit the browser after installation finishes



4. Start the moz/netscape binary (./netscape) 

Expected result:
netscape starts with JVM plugin, you can now go to any java enabled sites.

Actual result:
Rather than the browser starting you get a dialog box
"The program must close to allow a previous installation attempt to complete.
Please restart"

You see this twice after you start the mozilla/netscape binary before you
actually get a browser or profile manager window.

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 84896 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
v
Status: RESOLVED → VERIFIED

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.