B2G highlighter remains visible after closing toolbox

RESOLVED FIXED in Firefox 26, Firefox OS v1.2

Status

()

Firefox
Developer Tools: Inspector
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: jryans, Assigned: jryans)

Tracking

Trunk
Firefox 27
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox26 fixed, firefox27 fixed, b2g-v1.2 fixed)

Details

Attachments

(3 attachments)

STR:
1. Connect to device with App Manager
2. Debug an app
3. Pick some element with the Inspector
4. Close toolbox
5. The highlighter is still displayed in the app
(Assignee)

Updated

4 years ago
Assignee: nobody → jryans
Status: NEW → ASSIGNED
(Assignee)

Comment 1

4 years ago
Created attachment 805716 [details] [diff] [review]
Part 1: Fix explicit selection removal with remote highlighter

This cleans up a flawed part of the basic highlighter test.  The call to selection.setNode(null) would fail because walker.highlight would blow up when passing null to _installHelperSheet.
Attachment #805716 - Flags: review?(paul)
(Assignee)

Comment 2

4 years ago
Created attachment 805718 [details] [diff] [review]
Part 2: Convert basic highlighter test to Task.jsm

I've converted this test to use Task.jsm.  It makes it generally easier to read and simpler to extend in part 3.
Attachment #805718 - Flags: review?(paul)
(Assignee)

Comment 3

4 years ago
Created attachment 805721 [details] [diff] [review]
Part 3: Clear selection on remote inspector destuction

This fixes the main issue mentioned in comment #0.  The highlighter would correctly disappear after it timed out, but if you closed the toolbox before the timeout fired, the highlighter would remain forever.

This forces the selection to be cleared on inspector destruction.
Attachment #805721 - Flags: review?(paul)

Updated

4 years ago
Attachment #805721 - Flags: review?(paul) → review+

Updated

4 years ago
Attachment #805718 - Flags: review?(paul) → review+

Updated

4 years ago
Attachment #805716 - Flags: review?(paul) → review+

Updated

4 years ago
Keywords: checkin-needed
Whiteboard: [land-in-fx-team]

Updated

4 years ago
Whiteboard: [land-in-fx-team] → [land-in-fx-team], [needed-in-aurora-26]
https://hg.mozilla.org/mozilla-central/rev/fe907af7bc8d
https://hg.mozilla.org/mozilla-central/rev/022b9b96a7f4
https://hg.mozilla.org/mozilla-central/rev/67fb445b85a3
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Firefox 27

Comment 7

4 years ago
Comment on attachment 805716 [details] [diff] [review]
Part 1: Fix explicit selection removal with remote highlighter

[Approval Request Comment]
Bug caused by (feature/regressing bug #): new feature (app manager)
User impact if declined: red outline around elements on Firefox OS after debugging an app
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: no
Attachment #805716 - Flags: approval-mozilla-aurora?

Comment 8

4 years ago
Comment on attachment 805718 [details] [diff] [review]
Part 2: Convert basic highlighter test to Task.jsm

[Approval Request Comment]
Bug caused by (feature/regressing bug #): new feature (app manager)
User impact if declined: red outline around elements on Firefox OS after debugging an app
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: no
Attachment #805718 - Flags: approval-mozilla-aurora?

Comment 9

4 years ago
Comment on attachment 805721 [details] [diff] [review]
Part 3: Clear selection on remote inspector destuction

[Approval Request Comment]
Bug caused by (feature/regressing bug #): new feature (app manager)
User impact if declined: red outline around elements on Firefox OS after debugging an app
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: no
Attachment #805721 - Flags: approval-mozilla-aurora?
Attachment #805716 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attachment #805718 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attachment #805721 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Updated

4 years ago
Whiteboard: [needed-in-aurora-26] → [land-in-aurora-26]
You need to log in before you can comment on or make changes to this bug.