Closed Bug 914809 Opened 7 years ago Closed 7 years ago

[B2G][Buri][Browser]Browsing memory heavy websites triggers crash in browser; crash in mozilla::layers::GrallocBufferActor::ActorDestroy(mozilla::ipc::IProtocolManager<mozilla::ipc::RPCChannel::RPCListener>::ActorDestroyReason)

Categories

(Firefox OS Graveyard :: Gaia::Browser, defect, critical)

ARM
Gonk (Firefox OS)
defect
Not set
critical

Tracking

(firefox26 affected)

RESOLVED DUPLICATE of bug 901559
Tracking Status
firefox26 --- affected

People

(Reporter: gbennett, Unassigned)

References

()

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-4898b7f5-1add-4ab6-8d99-c01702130910.
=============================================================
Description:
After watching a few youtube videos or going to m.here.net and selecting the URL, the OS crashes.

Repro Steps:
1) Updated Buri 1.2 to Build ID: 20130910040201
2) Open browser.
3) Go to m.here.net and wait for the page to load.
4) Move the map around a bit.
5) Select the URL bar.

Actual:
The OS crashes.

Expected:
No crash occurs.

Environmental Variables
Build ID: 20130910040201
Gecko: http://hg.mozilla.org/mozilla-central/rev/be1053dc223b
Gaia: 6deda9d7c51f278443f704217eaed722044a03e7
Platform Version: 26.0a1

Notes: I was able to repro the crash on two other Buri 1.2 devices.
Repro frequency: 100%, 7/7
Youtube Video Repro: https://www.youtube.com/watch?v=mu_OpZ10WGA&feature=youtube_gdata_player
This is a known crash, and we don't seem to have a good open bug to be tracking these crashes ATM. Note that there are several other bugs which generate the same signature including Bug 901559, where the signature is being tracked as a top crash.
Blocks: GFXB2G1.2
It is possible that the patch in bug 912725 will fix this problem.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 901559
I can't reproduce this bug with the patch from bug 912725 applied (which fixes a crash with the same signature).
No longer blocks: GFXB2G1.2
Whiteboard: burirun1
You need to log in before you can comment on or make changes to this bug.