Closed Bug 91485 Opened 20 years ago Closed 19 years ago

Bold text cropped too much.

Categories

(Core :: XUL, defect)

x86
Windows 95
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 52596

People

(Reporter: neil, Assigned: mjudge)

Details

Attachments

(3 files)

Using Build ID: 2001071704

Steps to reproduce problem:
1. View the attachment

Actual results: bold text cropped to much.
Expected results: bold text cropped to same with as normal text.
Attached file Test case
Worksforme, build 2001-07-18-22 on solaris.  Attaching screenshot.

You _are_ accounting for the fact that bold characters are wider than normal
ones?
bold text should not be cropped the same as normal text. it's wider, and thus 
can't fix as much in the same area.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → INVALID
Yep. 
Status: RESOLVED → VERIFIED
Attached image Screenshot (Win95)
It might work on Solaris but I filed the bug on Windows 95.
Status: VERIFIED → REOPENED
Resolution: INVALID → ---
Summary: Bold text cropped to much. → Bold text cropped too much.
That looks like it may be a font metrics problem.... what font are you using? 
Or is this happening with all fonts?
Aha! You're onto something! It only fails when the bold font is synthesized.
It works perfectly for "separate" bold fonts (e.g. "Arial Bold").
jag, can you take a look at this?
Assignee: trudelle → jaggernaut
Status: REOPENED → NEW
methinks this is fixed now.
Status: NEW → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
Sorry, wrong resolution.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
It was fixed, but since I only have a vague idea what fixed it (someone fixed
some gtk font metrics code recently), I'm marking this WFM.
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → WORKSFORME
When was this fixed? I only have build 2001080904 which doesn't work.
Jag, doood! This is a win95 bug, not a gtk thing :-]
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Doh!

Need. More. Coffee.
May God have mercy on us all. The 212 bug spam-o-rama is Now!
QA Contact: aegis → jrgm
It sounds like this bug and bug 52596 share the same underlying problem.
Reassigning this bug to mjudge. Mike, feel free to hand it to someone else if
this isn't the same as bug 52596.
Assignee: jaggernaut → mjudge
Status: REOPENED → NEW
yes i think this does have something to do with the other bug. must be some kind 
of measurement glitch and not invalidating enough of the screen. I am marking 
this one as a dup

*** This bug has been marked as a duplicate of 52596 ***
Status: NEW → RESOLVED
Closed: 20 years ago19 years ago
Resolution: --- → DUPLICATE
Ah, the problem is that you're allowing too much space for bold text.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.