createMediaElementSourceNode() can't work with local file

RESOLVED INVALID

Status

()

RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: pyang, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

5 years ago
Created attachment 802767 [details]
sample-html.tar.gz

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20130826185301

Steps to reproduce:

1. New a audio tag element
2. Create a mediaElementSourceNode
3. Connect it to audioContext.destination
4. Assign audio element a local relative path, like sound/sample.ogg
5. play


Actual results:

Audio can be played correctly


Expected results:

No audio is played
(Reporter)

Comment 1

5 years ago
Created attachment 802779 [details] [diff] [review]
createMediaElementSourceNode-sample-html.tar.gz
(Reporter)

Comment 2

5 years ago
Created attachment 802780 [details]
sample-html.tar.gz
Attachment #802767 - Attachment is obsolete: true
Attachment #802779 - Attachment is obsolete: true
Component: Untriaged → Web Audio
Product: Firefox → Core
Version: 26 Branch → Trunk

Comment 3

5 years ago
This is expected I think, because we respect CORS rules.

Comment 4

5 years ago
Please reopen if you disagree.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(In reply to :Ehsan Akhgari (needinfo? me!) from comment #4)
> Please reopen if you disagree.

Couldn't that fail in a packaged app then? See the email discussion about on this for more detail.
Flags: needinfo?(ehsan)

Comment 6

5 years ago
(In reply to Jason Smith [:jsmith] from comment #5)
> (In reply to :Ehsan Akhgari (needinfo? me!) from comment #4)
> > Please reopen if you disagree.
> 
> Couldn't that fail in a packaged app then? See the email discussion about on
> this for more detail.

I couldn't understand from those emails whether the issue in the failing tests is related to CORS or not.  We need more detailed bugs on file, but I thought CORS does work in packages apps?
Flags: needinfo?(ehsan) → needinfo?(jonas)
(Reporter)

Comment 7

5 years ago
Since createMediaElementSourceNode() can work in package app, I will file a new bug for rest of the fail test.
You can do CORS requests from a packaged app yes. The only problem is if the server only wants to share a CORS response with a particular packaged app since we don't have a good way to identify a packaged apps. I.e. packaged apps doesn't have good origins.

But for servers that are fine with sharing a file with anyone, CORS from packaged apps should work fine.
Flags: needinfo?(jonas)
You need to log in before you can comment on or make changes to this bug.