Closed Bug 914984 Opened 7 years ago Closed 6 years ago

Enable Azure content for b2g

Categories

(Core :: Graphics, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla27

People

(Reporter: mattwoodrow, Unassigned)

Details

Attachments

(1 file)

Milan: Looks like this is all green now, but we need to decide if we should postpone landing this until after the merge.

I doubt there's much risk, but I'm fine with waiting too.

Can you please bring this up at the next daily, or whatever else you think is appropriate to make a decision here.
Flags: needinfo?(milan)
Comment on attachment 802798 [details] [diff] [review]
Enable

Review of attachment 802798 [details] [diff] [review]:
-----------------------------------------------------------------

::: gfx/thebes/gfxPlatform.cpp
@@ +278,5 @@
>                                   "layers.draw-bigimage-borders",
>                                   false);
>  
>      uint32_t canvasMask = (1 << BACKEND_CAIRO) | (1 << BACKEND_SKIA);
> +    uint32_t contentMask = 1 << BACKEND_CAIRO;

This will turn it on for Android too I think. Are we ok with that? (Although, I guess the pref would need to be set, so it is probably OK).
Attachment #802798 - Flags: review?(ncameron) → review+
Other than general goodness, are there measurable wins on performance, stability or correctness that we know of?
Flags: needinfo?(milan)
(In reply to Matt Woodrow (:mattwoodrow) from comment #1)
> Milan: Looks like this is all green now, but we need to decide if we should
> postpone landing this until after the merge.
> 
> I doubt there's much risk, but I'm fine with waiting too.
> 
> Can you please bring this up at the next daily, or whatever else you think
> is appropriate to make a decision here.

Let's do this next week and put it into 27.
(In reply to Matt Woodrow (:mattwoodrow) from comment #5)
> https://hg.mozilla.org/integration/mozilla-inbound/rev/1a8c638b3f1f

Nice!  Can you do some manual testing on B2G?  Most of the QA/dev has moved to 1.2 branch, we want to make sure we shake out any potential regressions out quickly.
https://hg.mozilla.org/mozilla-central/rev/1a8c638b3f1f
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
You need to log in before you can comment on or make changes to this bug.