Trying to show a notification with a valid icon URL fails to show the icon in the notification

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
5 years ago
5 years ago

People

(Reporter: jsmith, Assigned: qdot)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:koi+)

Details

(Whiteboard: [systemsfe] burirun1)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Build: Master 9/11/2013
Device: Unagi

STR

1. Go to http://mozilla.github.io/qa-testcase-data/webapi/notifications/index.html
2. Install the hosted app with permissions
3. Launch the app
4. Try to show a notification with a valid icon URL provided (e.g. http://mozilla.github.io/qa-testcase-data/webapi/notifications/qalogo.png)

Expected

The notification should be shown in the status bar with the icon specified if it exists.

Actual

No icon is seen with the notification.
(Reporter)

Updated

5 years ago
Blocks: 911002
blocking-b2g: --- → koi?
(Reporter)

Comment 1

5 years ago
Created attachment 802821 [details]
Logcat
Should be a dup of 901214 and will be fixed with the patch in bug 904298
(Reporter)

Comment 3

5 years ago
(In reply to Gregor Wagner [:gwagner] from comment #2)
> Should be a dup of 901214 and will be fixed with the patch in bug 904298

Are you sure? bug 901214 deals with permissions, where this just relates to getting the icon from a HTTP URL within an app.
(In reply to Jason Smith [:jsmith] from comment #3)
> (In reply to Gregor Wagner [:gwagner] from comment #2)
> > Should be a dup of 901214 and will be fixed with the patch in bug 904298
> 
> Are you sure? bug 901214 deals with permissions, where this just relates to
> getting the icon from a HTTP URL within an app.

Oh ignore me I mixed up some bugs. Somehow I saw a logcat that showed the process got killed because of missing 'desktop-notification' permission.
(Reporter)

Updated

5 years ago
Whiteboard: [systems-fe]
(Reporter)

Updated

5 years ago
Whiteboard: [systems-fe] → [systemsfe]
(Reporter)

Updated

5 years ago
blocking-b2g: koi? → koi+
Whiteboard: [systemsfe] → [systemsfe] burirun1
Peter Dolanjski changed story state to started in Pivotal Tracker
When firing through new API, we send a system message with an imageURL property, not icon as expected.
Assignee: nobody → kyle
Hey peter, should we show the app icon of the notifying app if there isn't an icon specified for the notification?
Flags: needinfo?(pdolanjski)
Ok, I was wrong on comment 6. We convert imageURL to icon in shell.js, so icons work fine in B2G Desktop 2013-09-19. The problem comes in the test app listed in comment 0. The property block sent as part of the new Notification() call specifies iconURL, not icon, as is laid out in the spec. This is why icons don't work in the test app.

Marking WFM. Will break out new bugs for writing tests for icons for notifications and updating the very very wrong uitests, as well as possibly defaulting to app icons depending on what pdol says.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Kyle Machulis changed story state to accepted in Pivotal Tracker
Kyle Machulis changed story state to accepted in Pivotal Tracker
Kyle Machulis changed story state to accepted in Pivotal Tracker
(Reporter)

Comment 12

5 years ago
Yup. Confirmed this is a bug in my app - just patched and fixed it. Confirmed I'm seeing icons now.
Status: RESOLVED → VERIFIED
Flags: needinfo?(pdolanjski)
You need to log in before you can comment on or make changes to this bug.